39

I'm currently using a Mid-2015 MacBook pro and running Catalina's latest build on it. Although for quite a long time anytime I connect the MacBook to an external display via HDMI it seriously slows down. when I check the usage via activity monitor I'll notice a huge spike in activities even if I'm not doing anything on the system

Connected to display Spike drops immediately I disconnect the display

I've tried so many things like mission control, Pram reset, opening the case and cleaning dust out.

0

11 Answers 11

12

Kernel task exists to slow things down when the system gets hot. Have you ruled out a temperature rise when running more pixels adds GPU and CPU load?

You can test this by connecting a display of much lower resolution or decreasing the pixels being displayed in some cases. In other cases no amount of slight changes will reduce the CPU load you show. Since that fluctuates - what are the energy tab showing for the last hour(s) of usage?

Especially if you run closed clamshell mode.

I would expect your Catalina activity monitor to show a GPU tab but maybe that’s only on some hardware. I also would be sure you’re running the latest EFI and firmware and reinstall the OS from recovery on top of your system. Check system information and build which are circled in red.

enter image description here

0
14

enter image description hereExperiencing lag, slowing down mac when connecting an external monitor. We have had this experience with several Macs, even a MacPro 2020 with everything maxed out.

  • Do the following to resolve this:

  • Go to display settings

  • Switch "Default for Display" on your external monitor display settings

  • Hold OPTION and click Scaled

  • Check "show Low-Resolution modes"

  • Select desired resolution with (low resolution) attached to it

  • Mac Speed Normal!

Enjoy!

Youtube Video: https://youtu.be/RAk060t_8S4

3
  • This should be the accepted answer!
    – ExTexan
    Commented Apr 1, 2022 at 11:32
  • 5
    Unfortunately not working on 12.4 (21F79)
    – cV2
    Commented Jun 10, 2022 at 16:57
  • Tip: I had to hold the alt key while clicking "Scaled" for the resolutions to show up. I'm on Big Sur. Commented Mar 8, 2023 at 15:52
11

Restarting SMC chipset helped fixing it.

  • Shut down Mac
  • Hold. CTRL+OPTION+SHIFT+POWER button for 10 seconds
  • Start mac
2
  • 2
    I got the same issue as OP. My MBP 2015 has an AMD Radeon R9. It had been working properly until I plugged an external monitor (Dell Ultrashap 24"). The OS became laggy. Unplug the monitor then it back to normal.
    – Andree
    Commented Nov 4, 2021 at 12:50
  • 3
    @Andree is your experience also that one SMC reset is enough to know if that was causing inadequate cooling response instead of the Mac just being thermally throttled when the GPU is engaged.?
    – bmike
    Commented Jul 19, 2022 at 12:16
4

Make sure all monitors are set at the same refresh rate, probably 60Hz.

This fixed the issue for me when using the laptop display along with a single non-Mac external display to extend the desktop.

My external monitor was set to 60Hz and my laptop display was set to ProMotion. I changed the laptop to 60Hz and the lagginess went away. I was shocked the solution was that easy, honestly.

I tried switching between USB-C and HDMI, using powered and non-powered monitor connections, and switching different USB ports, but none of that worked. I kept my external display at native resolution.

How did I diagnose this?

I was looking at the Activity Monitor for both GPU and CPU and noticed that when scrolling IntelliJ with just the laptop monitor, GPU usage for the app was much higher than when an external monitor was plugged in and I was scrolling on that (~50% vs. ~12%, respectively). I figured something was keeping IntelliJ from fully utilizing the GPU on an external monitor, so I tried syncing refresh rates across monitors (60Hz), and now I see GPU usage in the high 30's and the lagginess gone.

This is for a 16" M1 Max with 24 GPU cores running Ventura 13.4.1.

4
  • Evidence of confirmation: I just now experienced the lagginess issue again and wondered if perhaps my fix was ineffective. But when I went to check the display settings, I saw that my laptop display had reset from 60Hz to ProMotion. When I set it back to 60Hz, the lagginess on the external monitor disappeared.
    – einnocent
    Commented Jul 24, 2023 at 16:55
  • 1
    can confirm. Setting it from 50 to 60HZ fixed the issue.
    – callback
    Commented Jul 25, 2023 at 9:32
  • Confirmed somehow. I had the dynamic refresh rate option on the second screen. Much better now. Commented Sep 5, 2023 at 22:53
  • You're a genius! I had the same problem using Pycharm with my external display, but now it is fixed!
    – Altantur
    Commented Dec 26, 2023 at 12:56
1

The reason is heating your MacBook. If you can keep your MacBook cool using AC/Fan it will work better.

1

I had the same problem with the Macbook Pro 2019 Intel i9. The kernel task used to go crazy when connected to an external monitor. Did an SMC reset, an NVraam reset and nothing helped.

Apple service told me it could be a Motherboard issue.

Instead, I got my MacBook serviced and cleaned up the dirt from the fans, and Boom it solved my issue.

0

Lowering the refresh rate of the screen can help significantly as wellRefresh rate

1
  • For me I actually found that raising it helps! (30 to 50hz)
    – sir-haver
    Commented Aug 12, 2023 at 19:40
0

After many tries, I found a solution that worked for me.

In my case, it was due to high temperatures on (I guess) my MacOS Pro 2019 ( and the HDMI adapter. After some tests, having a fan pointing to both the computer and adapter solved my problem!

2
  • 1
    What is a MacOS Pro 2019? Do you mean MacBook Pro?
    – Allan
    Commented Mar 30, 2023 at 17:36
  • For me, just plugging in the HDMI directly into MacBook M1 Pro instead of through a dock station (which had keyboard and mouse plugged in as well) worked for me. Not sure if it's due to the dock station heating up or if it's slow in general.
    – Bugs Buggy
    Commented Apr 3, 2023 at 16:43
0

I was having the same issue on my MBP 2017 running on MacOS Ventura 13.3.1 which had a 4k external monitor connected over HDMI.

Every time I played a youtube video(not even a 4K), the laptop was lagging and in the Activity manager I was seeing high CPU utilisation by kernel_task. There was no issue if I used the laptop without an external display.

After some experimentation, I figured out that the issue happened only when I connected the external display and power adapter on the same side of the laptop.

It fixed very easily after connected both on them on either side of the laptop, the display on the right and power on the left.

Before: enter image description here

After: enter image description here

0

I recently encountered performance issues when using an external display with my MacBook Pro 16-inch, 2019 model.

After trying various troubleshooting steps, I discovered a simple yet effective solution. I switched my external display to be the main display, and this resolved the performance issues. Interesting, huh?

-1

After upgrading to Mac OS Ventura 13.3.1 version. My MacBook Pro slowness issue resolved. You can also upgrade.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .