2

I have new Macbook Pro 16' with Mac OS Catalina (obviously I can't downgrade)

From time to time, music stops playing inside the headphones (WF-1000XM3). The headphones are still connected, but sound output switched from the headphones. Changing sound output to the headphones will produce spinning wheel, but will not actually change it.

  • Turning off and on the headphones sometimes fixes the issue.
  • Resetting BT module temporary fixes the issue (SHIFT + OPTION + click on BT in menu bar) Debug BT menu bar

It's was really frustrating, How I fixed it is below.

3
  • I have these same headphones and they’ve been nothing but Bluetooth purgatory. If there isn’t line of sight between the a Mac and the headphones, forget about reliable connections. I switched to a Sennheiser M2 and solved all the issues immediately – Allan Apr 11 '20 at 13:05
  • Hey @Allan, Thank you for your comment. I agree with issues you mentioned, but the issue I mention happens even if you are literally next to the mac. It's Catalina specific and I wouldn't be surprised if it happens with all headphones. – Vojtech Vrbka Apr 11 '20 at 15:06
  • I don’t think it’s Catalina specific because the issue existed on El Capitan as well. I had no problem with my substantially cheaper Jaybird X4s. Those worked perfectly but didn’t have the noise cancellation I needed. – Allan Apr 11 '20 at 16:22
1

Forcing headphones to use aptX codec fixes the issue.

How to change it?

  1. Head to https://developer.apple.com/bluetooth/ Apple developer website preview

  2. Download additional tools for Xcode (you might need to sign in with your Apple ID) Downloads page on apple Developer Portal

  3. Open downloaded image and open Hardware folder Downloaded additional tools

  4. Move BT Explorer to your application folder and open it BT Explorer app

  5. Select Force use of aptX BT Explorer app opened

  6. Disconnect your headphones and connect again

  7. Hold OPTION/ALT key and click on BT in the menu bar, find your headphones, it should show Active Codec: AptX enter image description here

  8. From my experience this should fix the issues.

Edit: Some people reported that disabling Ask Siri reduces the issues as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .