3

I'm reaching out to you because I'm at my wits end. I've been trying to figure out why using rsync over ssh is so slow on my MacBook (15 inch from 2015). Basically I'm trying to backup my home folder to a remote server over ssh, and it runs very slow.

First thing I did was monitor the remote server to check for CPU/Disk usage and it's barely doing anything.

Then I tried all sorts of combination to lighten the already non-existent CPU overhead of the ssh transfer but to no avail. Speed remained at around 0.5MB.

I tried the same rsync job from a wired Debian server and it uploaded at 100MB/S (I've got a fiber connection at home). So clearly the remote server can take it.

So I thought it must be a WiFi limitation, but just to make sure I booted up a Linux Virtual Machine on the very same MacBook Pro that couldn't reach 1MB/s upload speed with rsync and guess what? 50MB/S upload speed to the server.

BTW I tried both rsync versions, the one that came with Catalina and an updated one from homebrew.

I cannot for the life of me figure out what is making rsync so slow on my MacBook when a VM running on the very same MacBook reaches 100x superior speed!

0

1 Answer 1

1

2 years later I am trying to find out why a similar thing is happening to me.

I am using the rsync that comes on macOS Monterey; when running

rsync --version

I get

rsync  version 2.6.9  protocol version 29

I assume that the outdated version of rsync is the culprit.

As to what happened when you ran it with homebrew what comes to mind is the precedence in your PATH. Is it possible you were still running the built in macOS rsync as opposed to the rsync installed by homebrew? You can test it out by running the version command and then try explicitly running the rsync installed by homebrew with

/usr/local/bin/rsync --version

to see if you're running the right one.

I know it's years later but I am curious to see if the homebrew version would also have this problem.

1
  • Hello, here is the thread where i found the solution : truenas.com/community/threads/… See the last post, to solve my issue I had to use this ssh parameter "ProxyCommand nc %h %p" This seems specific to ssh on Mac OS
    – Sn0
    Mar 2, 2023 at 10:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .