0

I'm trying to unlock an old iPhone 5c to access some pictures I have on there. Every time I try to unlock it, it takes me to the white screen with the "Hello" message, and then it tries to connect to a network (I have been able to connect it to my home Wifi) and I get the "Your iPhone could not be activated because the activation server is currently unavailable" message. I have tried holding the home and power button at the same time, connecting it to iTunes, and none of that has worked. The phone has an old SIM card in it, but I just want to be able to unlock it to access photos. Any help would be greatly appreciated!!

1

Do you have it backed up to iCloud, Google Photos, or OneDrive? If not, then try activating the phone with a different Apple ID. This has helped me in the past. If this is not helping, then contact your carrier and see if they can help. Usually they are the best people to contact when there is an activation lock. Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .