1

My iPhone has been set to store contacts to an Exchange account by default. 2 years ago I changed workplace and my Exchange account was discontinued. I now realise that all the (300ish) contacts on my iPhone "belong" to that discontinued Exchange account, but they somehow show up perfectly well and ready to use for calling and texting on my iPhone. - That's why I didn't notice until now :-(

So I wanted to secure the contacts. Turned on iCloud syncing of contacts, and successfully sync'ed three contacts that I must have somehow saved in the right place on the phone. But the majority of my contacts do NOT show up on iCloud. I guess because iCloud doesn't have the password for the Exchange account, and therefore doesn't think it has legitimate access rights.

But since I actually see and can use all the contacts on the phone, I imagine I must be able to copy and store them somehow. But how?

If I select an individual contact on the phone I can "share contact" via eg text message to myself just fine. I just can't stand the thought of manually sharing and then saving all contacts.

I've tried USB connecting the iPhone to macbook with iTunes, but that does not seem to give me the option of actually SEEING or managing contacts, just selecting if I want to sync the contacts to eg iCloud.

  • I faced similar issue when i left company i just saved contacts again to different account. I think apple has removed this feature in ios 13 – Ciasto piekarz Apr 12 at 11:40
  • Or go to settings > Contact > Default Account where you want to save. Then from contacts save them again. If you have any of gmail account in default account it will also show up in your google contacts when you sign in to google – Ciasto piekarz Apr 12 at 11:43

You must log in to answer this question.

Browse other questions tagged .