2

When macOS tells me an update is pending and I choose to do that overnight, I often still have a few Terminal windows open when I leave for the day. The next morning, macOS says that it politely declined to close those windows, and thus not try to update. So my workday starts with twenty minutes of waiting for the update to run.

How can I tell macOS to kill Terminal and anything else that might prevent the update from running?

Catalina 10.15.4, if it matters. In Preferences > Software Update > Advanced, all the checkboxes are checked.

2

The easy way to do this is to change settings and allow terminal to exit.

Look for Ask before closing in Profiles under the Shell tab.

  • select Never

enter image description here

I prefer to list the processes I am willing to have killed without a dialog. I should probably add bash and zsh to my list now that they are mixing use and not always default for me. Another take on this list for older OS is here.

2
  • 1
    Ah, so it's up to Terminal (and anything else) to let Update close it. Update doesn't itself have a checkbox "behave rudely." – Camille Goudeseune Apr 10 '20 at 16:13
  • @CamilleGoudeseune there’s always sudo softwareupdate -ai --restart where you can authorize the restart. Or just log out every night (Or allow automatic log out on a timer) and the settings will work as expected. – bmike Apr 10 '20 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .