0

I have a flash drive formatted to ExFat with multiple folders, one of which contains various mp4 files. Likely because of some stupid decisions which include "Forcing the computer to shut down in the middle of a process because it appeared to be at a standstill," the folder with the mp4 files no longer display its contents when I click on it. Instead it shows me an empty folder for a few seconds before shutting finder down on its own.

All of the other folders are fine, and spotlight searching the flash drive shows the files, so they're still there somewhere. I can play them as normal through spotlight search, but attempting to click "Get info" results in Finder shutting down again. I can't move the files out of the folder through spotlight search either.

I've tried copying the folder from the flash drive to the desktop, and it gives that window that says "Copying x amount of files," but after ejecting the flashdrive, the files no longer show up in the spotlight search, as if none of the files actually transferred. Opening the desktop folder also results in Finder quitting.

Just before all this occurred, I had a problem with the Spotlight Comments section where none of the words would display, but they still popped up in Spotlight searches. Likely due to similar stupid decisions. (I don't learn, apparently)

I've considered plugging the flash drive into another computer to see what it does, but I'm afraid it might somehow make things worse, and the folder on the flash drive may be the only copy of it left, depending on if the one I copied to the desktop actually contains the files or not.

I've tried moving the folder from the desktop onto another flash drive just for the hell of it, but that appears empty too, and also quits Finder when opened. I tried re-indexing the desktop folder, though its reason for not working may be because the files aren't there. I tried running mkdir ${TMPDIR}/com.apple.IconServices in Terminal too, from another suggestion, but the flash drive wasn't plugged in when I did. I'm just afraid to do anything to the folder on the flash drive itself because it may be the only copy I have left, and I don't want to make things worse.

I don't know if any of this is important, but the computer I'm using is a Mac OS X Lion, made in early 2008 with a Windows 7 partition (I've been using the Mac side though.) It's pretty ancient, and I'm pretty stupid, so I'm not surprised I'm having problems.

  • If you still can access all files via Terminal, it might be easiest to copy the whole content of the flash drive to your local drive (or to another flash drive) and reformat the drive. – nohillside Apr 8 at 16:23
  • @nohillside I was able to move the files to a new folder using terminal, it worked perfectly and they're all able to be viewed as normal now! Thank you so much! – Definitely-Not-LordEnglish Apr 8 at 21:55
0

If you still can access the content of the drive via Terminal:

  • Use rsync, ditto, or cp to copy the content of the whole flash drive onto another drive
  • Reformat the flash drive
  • Copy your data back

I'm not sure whether it's wise to trust a drive which doesn't seem to fully work anymore. Maybe replacing it with a new one is the safer approach.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .