0

I need to have an exe file found in the terminal with "which FILE" command. I set the PATH to this file but I cannot find the file with which?

I added

export PATH=$PATH:/Users/neurolab/Desktop/Stephan/Programmes/MSM_old/msm_mac

in ~/.zprofile. msm_mac is the binary.

When I type in which msm or msm_mac, the result is msm not found.

Current value of the PATH:

/Users/neurolab/opt/anaconda3/bin:/Users/neurolab/opt/anaconda3/condabin://Users/neurolab/Desktop/Stephan/Programmes/freesurfer/bin://Users/neurolab/Desktop/Stephan/Programmes/freesurfer/fsfast/bin://Users/neurolab/Desktop/Stephan/Programmes/freesurfer/tktools:/Users/neurolab/Desktop/Stephan/Programmes/fsl/bin://Users/neurolab/Desktop/Stephan/Programmes/freesurfer/mni/bin:/Users/neurolab/Desktop/Stephan/Programmes/fsl/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/spjder:/usr/local/munki:/opt/X11/bin:/Users/neurolab/Desktop/Stephan/Programmes/workbench/bin_macosx64i:/Users/neurolab/Desktop/Stephan/Programmes/MSM_old/msm_mac

I am using MBP 2019 with Catalina

What can I do?

Best,

1

The PATH is a list of directories so need to add

/Users/neurolab/Desktop/Stephan/Programmes/MSM_old

to your PATH (and re-read ~/.zprofile) to make it work.

| improve this answer | |
  • thanks. It’s a good idea and does absolutely not hurt to revise the basics .. at least from time to time ;-) – Johnmager Apr 8 at 14:53
  • Thanks alot! I added only the the directory path but it is still the same. What you mean by re-read? – Dr. S Apr 8 at 14:58
  • @Dr.S Open a new tab in Terminal, or run source ~/.zprofile. – nohillside Apr 8 at 15:04
  • okay thanks a lot! It is solved – Dr. S Apr 9 at 7:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .