0

I have a severe issue with an MacBook Pro Mid-2012 (serial number is C1MK9X6ZDTY3; it is a MacBook Pro 13-Inch "Core i5" 2.5 Mid-2012). In 2017, the RAM was upgraded. Also the internal HD was replaced with an SSD.

Recently, the MacBook's OS was updated to Catalina because some other software required the upgrade. The update essentially worked just fine and I could work with the laptop. However, a few days ago the system slowed down significantly up to a point where it's not usable anymore. Right now, directly after rebooting, I can hardly open any apps. The colored spinning wheel appears immediately and the machine more or less freezes. Also I cannot properly open Finder, etc.

I tried to connect the SSD externally via USB to another Mac. The behavior is the same.

I did some checks on the SSD:

  1. Disk Utility says: https://imgur.com/a/ljvuHHt

  2. The log when trying to do "first aid" on the disk says the following: https://imgur.com/a/FgXVoDu

As you can see, there are some errors. Could they be related to the OS update?

  1. I also installed DriveDx: https://imgur.com/a/BhBA6aa Looks good, if you ask me.

Can you help me identifying the issue here?

3
  • If the new OS worked perfectly well for some days before the problem started, then I would be wary of blaming the OS. The drive seems physically OK, from DriveDX, but it's possible that some issue with the files or format exists. It could also just be some software that is using all the CPU and slowing everything down. You could just wipe the disk and restore from your backup. If that doesn't fix it, then it's a software issue. See if you can get Activity Monitor up and see what's using all the CPU or Memory. – benwiggy Apr 8 '20 at 13:12
  • thanks, will try to get up the activity monitor. Do you know how to start the Activity Monitor without using Finder? Also Spotlight does not work. And did you see the Errors shown from First Aid? nchildren does not match drec count etc.? Does this indicate something? – beta Apr 8 '20 at 14:53
  • Oddly, I somehow got into the Activity Monitor and killed a process kalled pkd. Now everything is back to normal. How strange. Now I have to find out, where this is coming from and why it was blocking everything. – beta Apr 8 '20 at 17:21
0

I've also struggled with the same Macbook type and encountered a similar problem. Replaced the HDD with a SSD and it worked for almost two years, until the Mac became really slow.

Looks like the SATA cable is broken and needs replacement. See these ifixit instructions for the replacement.

The SSD I've used was a SanDisk SDSSDA-480G which is really slow now, even when I put it in an USB enclosure on another Mac. Writing is now limited to 2MB/s, while reading is still faster (around 250MB/s). I've verified with a different SSD and HDD that the enclosure isn't the problem for those low speeds. Looks like the disk is also damaged as side effect from the SATA cable.

I've replaced cable and SSD with new components and the same machine is now fast again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .