I am running OS X Lion 10.7.2 and have a bluetooth keyboard, magic mouse, and magic trackpad. Over the weekend the behaviour of the right shift key changed in such a way that if I use it to capitalize a letter or shift a number to get '*' or '(', etc. it will randomly lose focus on the window, or jump to another part of the screen (often highlighting part of it so I end up over-typing what was highlighted (say in a text entry form such as this).

I can really reproduce this in Terminal, just by typing ********* (and have reproduced it just now in Chrome by doing so). This is frustrating beyond words, and I've gone through and disabled Mission Control keyboard shortcuts, I've stopped almost every program to see if something like that was reproducing it (new things installed/updated shortly before this started happening was MenuPop and iTerm2). Initially I suspected LaunchBar (having read about oddness with the clip merge feature, which I've disabled) and MenuPop, but with both of those not running, I still get the same behaviour. In Terminal it's the worst, but does happen randomly with other apps where I'm entering text.

Has anyone seen this before? Google isn't giving me much help.

This is a screenshot:
enter image description here

  • Might be time to replace the batteries on the keyboard.
    – KidPub
    Commented Jan 30, 2012 at 20:14
  • No, batteries in the keyboard are fine (replaced a few days ago). I did just try turning off the trackpad and turning it back on again (removed and reinserted the batteries) and so far I've not seen any strange behaviour since. Something wonky with the trackpad by the looks of things so far.
    – vincent
    Commented Jan 30, 2012 at 21:07
  • Probably not what you're seeing, but I've had similar unexpected things happen when my keyboard nudges up against the trackpad enough that it registers a mouse-down event.
    – KidPub
    Commented Jan 30, 2012 at 21:59
  • This sounds like a problem with the mouse, not the keyboard. I see you wrote a comment below stating "something wonky with the trackpad"; can you edit the question to put a more appropriate and accurate title?
    – bneely
    Commented Jan 31, 2012 at 1:30
  • If I do that, the embedded image goes away, so just adding a comment. It's been about 12hrs since I removed and re-inserted the batteries in the magic trackpad and I've not seen the strange highlighting/bouncing issues. I had tried power cycling it and disconnecting it via the bluetooth prefs yesterday and that hadn't made a difference, but removing the batteries definitely has. Not sure why it all of a sudden started, but it seems to be ok now.
    – vincent
    Commented Jan 31, 2012 at 6:35

3 Answers 3


Alright, just 'fixed' it. It's caused by that plastic divider on the Magic Wand! I guess the way it's holding the trackpad with the keyboard causes it. I've removed the plastic and moved the trackpad and keyboard in contact with each other. No more problem!

  • Nice detective work!
    – Mike Hofer
    Commented Apr 18, 2012 at 20:43
  • Yeah, I believe this was definitely the cause of the original problem, as removing the batteries meant taking it out of the Magic Wand as well. I think it's just how it sits, possibly pressing on the trackpad in a certain way.
    – vincent
    Commented Apr 19, 2012 at 15:06

Well, it's been a few days and the answer was most definitely the magic trackpad was what was causing this. I cannot explain why, but removing the batteries and re-inserting them did the trick. It's possible that it was due to a phantom mouse-event and when I removed the magic trackpad from the magic wand, and then put it back into place it didn't sit as snug as it had earlier (but I hesitate to think it was that since some apps seemed to register the strange behaviour more frequently than others did).


Alright, so this is happening to me as well but removing the batteries didn't solve it. First, thanks for figuring out that it's interference from the MagicTrackpad rather than just the bluetooth keyboard. I was going nuts trying to fix the keyboard. However, when I turned the trackpad off, problem solved.

The issue I'm having is if I type anything with the right Shift key pressed, it doesn't register until I let go of the key. So, if I'm typing an entire word in all caps with the right shift key pressed, my screen displays nothing until I let go. Really strange.

When I turned off the trackpad, no problem. And I am also using the Magic Wand combo bar. I'm curious if you did anything else besides the batteries as that's not working for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .