1

Running the latest MacBook Pro from Fall 2019. 2 TB internal SSD. Was doing a build and the power cut out. Restarted the computer and found a folder that I could not delete. Tried all the tricks:

  1. sudo rm rf * - did not work said directory not empty
  2. ls -la what files are in here, no files are in there
  3. Ok, let's just rm -rf * in this folder - weird a bunch of files show up related to my build, but rm gives me the a bunch of errors e.g., rm: Filename.ext: No such file or directory
  4. Alright, reboot into recovery mode and try the same thing - same issue
  5. OK, run First Aid - ah we got a problem (see pic below)
  6. Run First Aid again, problem not going away
  7. Run First Aid one more time, still getting the same error
  8. Fine, mount the volume and then fsck_apfs it using terminal - same error
  9. OK, let's turn off FileVault and try everything all over again - no luck

I've escalated to as high as I think. Anyone want to take a stab at this? Last step for me is to format the disk but that's super annoying.

Thanks!

enter image description here enter image description here

6
  • 1
    You should try rm -Rf * from the directory you want to remove. – Natsfan Apr 10 '20 at 17:05
  • like @jmh said, try sudo rm -fr nameOfFolder/. It should be blown away. – Noah Broyles Apr 10 '20 at 17:11
  • No luck, getting the error "Directory not empty", attached a screenshot – Kirk Ouimet Apr 10 '20 at 22:33
  • 1
    Try doing sudo chmod 777 -R foldername then sudo rm -rf foldername. – Todd Apr 14 '20 at 3:17
  • Or just sudo rm -rf foldername – Tyler Christian Apr 14 '20 at 15:02

You must log in to answer this question.

Browse other questions tagged .