every time that my 2007 macbook with lion goes to sleep, either manually (closing the lid) or timing out, i have to restart my computer to connect to the wireless network. It fails to detect any networks at all until I restart, then it connects to my default network no problem. What can I do?

3 Answers 3


Clear the network out and re-setup it.

Otherwise, I've run into this issue before, what brand of router are you using? And does it happen with other networks apart from this one?

Related: Why doesn't Airport reconnect after sleep or shutdown?

  • I'll give it a shot. But it won't recognize any networks after sleep. Thanks.
    – Scott
    Commented Jan 31, 2012 at 2:34

Apple claims to have addressed this issue with the OS X 10.7.3 update which, amongst other things, has a fix to:

Resolve a Wi-Fi connection issue when waking from sleep

Ars Technica reports that some people have had problems with the update but they are resolved by reinstalling using the Combo Updater.


I also had this problem on Retina running Mountain Lion.

After waking from sleep, WiFi doesn't automatically reconnect although it connects just fine when I manually select the network from the list.

I found a working fix here, kudos to Morris for posting.
For convenience, I reproduce his post here:

The first step is to create a new 'Location' under 'Network Preferences' and use that as default. I have deleted all old locations, don't know if that is necessary though.

The second step is to follow Apple's advice in Troubleshooting Wi-Fi issues in OS X Lion and Mac OS X v10.6.

Expand the Solution section under Symptom: The network connection drops unexpectedly and follow the steps listed under Symptom: After restarting or waking from sleep, my computer might not connect to the Internet.

Just make sure you write down all the passwords for the networks you want to keep as deleting the keys in keychain will permanently remove them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .