My iPad's name used to be Behdad's iPad for many years, but a few days back, it was automatically changed to Behdad's iPad (4) and when I manually deleted the number, it was soon changed to Behdad's iPad (8). Now that I'm writing this, it is currently Behdad's iPad (543), which has been changed from Behdad's iPad (284) from yesterday!

iPhone and iPad names, yesterday iPhone and iPad names, today

A few points to consider: It all started when I installed YazFi package on my ASUS RT-AC87U router with Asuswrt-Merlin 384.13_2 firmware on it and my current network configuration is as follows:

  • I have two networks, one is and another is
  • All my devices occasionally connect to any of those networks, including my iPhone and my MacBook Pro.
  • This naming thing happens on both my iPad and MacBook Pro (but not to this extent, as it is currently sitting on Behdad's MacBook Pro (7), but not to my iPhone.

Do you have any idea on why this happens and how can I make it stop? I'm worried it messes something with iCloud, as these names appear on my iCloud device list.


3 Answers 3


This does not mess up iCloud devices, the device is getting the name from the router and reporting it. As soon as you rename the device or fix the network to assign a different name, iCloud will reflect the current names quickly.

It definitely is made worse by YazFi, because since I uninstalled it from my router, all my devices have kept their names. I'm going to ask its developer also. This can happen on any network, however with bonjour sleep proxy and dns/dhcp not cleaning old records at the same rate as iOS devices reconnect after sleep.

YazFi's developer had asked people to reply to a thread in SmallNetBuilders forum regarding any issues. Several others created accounts there, but looks new users need to gain a few points to be able to post on the forums (similar to how new users can’t comment here without reputation or make edits without approval).

Getting enough momentum posting on SNB forums to link to this question might help others see it.

Editors note: this answer came from edits to the question so I moved it to the answer. I encourage others to put up a better answer or edit this as needed.

  • Can anyone vouch for or against adding a space after the device name suppresses the number increments? apple.stackexchange.com/a/170207/5472
    – bmike
    Feb 1, 2021 at 17:37
  • I tried adding a space on YazFi 3 and it didn't help. YazFi's current version is 4.1.4 but it may take me a few days to test that since I no longer have YazFi on my home network.
    – Behdad
    Feb 2, 2021 at 16:19
  • Thanks @Behdad it was a long shot - good to know either way
    – bmike
    Feb 2, 2021 at 17:52

I can't add a comment...but I'm the YazFi developer. See this post: https://www.snbforums.com/threads/error-on-all-apple-devices-the-name-of-your-computer-is-already-in-use-on-this-network.63763/#post-665905

  • Thank you for hopping on and disclosing you are the developer. People generally have lots of router questions. :)
    – bmike
    Feb 20, 2021 at 22:44
  • Thanks @jackyaz for the response. Actually after upgrading to YazFi 4 I haven't had this problem anymore. I will update here in case I run into the same problem in the future. Thank you for all the good work.
    – Behdad
    Feb 21, 2021 at 14:32

When I originally asked this question, latest YazFi version was 3. As of writing this the latest version is 4 and I haven't had this problem with YazFi 4. So if you have this issue on YazFi 3, update to version 4. I hope this helps.

Update: 7 months later and I can confirm YazFi 4 fixes the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .