1

I'm currently on Catalina 10.15.4 and recently started seeing a popup whenever I try to take full screen screenshots. A window pops up saying "Your screenshot can't be saved. Unable to capture window image." I've tried to capture via the grab tool and also pressing ⌘ Command ⇧ Shift 4 then Space then and then clicking.

I've tried changing the default directory that my screenshots are saved to from the desktop to a folder called screenshots but this didn't help. defaults write com.apple.screencapture location ~/Screnshots.

Any ideas why this might be happening?

  • 2
    Does the directory ~/Screenshots exist? It's not a directory that exists by default. – Allan Apr 5 '20 at 2:10
  • 1
    @Allan I don't think it matters? If the screencapture location doesn't exist, the file will just be saved to the Desktop instead (under normal conditions). – Nic Apr 5 '20 at 5:42
  • Try creating a new user account. Does the screenshot tool work in the new user account? – Nic Apr 5 '20 at 5:43
  • @Nic, does it? Why would it "know" to default somewhere else? – Allan Apr 5 '20 at 6:09
  • @Allan - On 10.15.4 it does default to ~/Desktop if ~/Screnshots (or whatever location you set) does not exist. It also defaults to ~/Desktop if location is not set at all which it isn't by default - the initial result of defaults read com.apple.screencapture location is "The domain/default pair of (com.apple.screencapture, location) does not exist". – lx07 Apr 5 '20 at 7:05
1

Does your Mac have a Touch Bar? If so, check the location shown there after you press Cmd + Shift + 4. Is it a valid folder?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .