I'm in the process of migrating from Mojave (on the internal HDD) to Catalina (on an external SSD).

Under Catalina, if I try to go to "Security & Privacy" in System Preferences, it hangs, and becomes unresponsive until I Force-Quit it.

I've seen suggestions specific to other System Preferences panes hanging, under different macOS releases, but not specific to Catalina or to "Security & Privacy."

NEW 4/28/2020

I finally found the time to try a "safe mode" boot on the Catalina side today. At least, I think it was a safe mode boot -- it didn't say anything about safe mode, the way it does for recovery mode. I held the shift key while the switchover was in progress, up to the point where it asked for my password (both load-source drives, i.e., both the internal HDD and the external SSD, are encrypted), and then held it for quite a while after giving it my password.

It asked for my password a second time, just before the desktop came up, and the secondary screen did not come up (thereby dumping a s---load of icons onto the main screen desktop).

Attempting to go to "security and privacy" in System Preferences still threw up a pinwheel mouse-pointer. While it was doing that, I tried Disk First Aid. It was then that I realized that whatever was locking up System Preferences was also eating up lots of CPU time: performance was extremely sluggish just navigating to Disk Utilities. Once Disk Utilities came up, it showed both "SanDisk SSD" and "SanDisk SSD - Data"; I ran Disk First Aid on both of them. It appears to have found nothing.

A symptom I failed to mention before, but which may be related

When shutting down on the Catalina side (and this has been happening for about as long as the System Preferences lockup, again only on the Catalina side), Firefox will refuse to shut down unless forced. In fact, as I recall, if I'm on the Catalina side, Firefox will come up without my explicitly launching it. Even if I explicitly closed it before shutting down. Could this be a piece of the puzzle?

  • What method are you using to migrate from Mojave to Catalina? It sounds like some files from old OS may be carried over to the new OS causing incompatibilities?
    – adamxweb
    Apr 15, 2020 at 4:36

3 Answers 3


First, try booting Safe Mode. This allows your Mac to check itself for issues. The way to do this is reboot and press Shift.

If that doesn't work, try running First Aid in Disk Utility.

If that doesn't work, try reinstalling macOS from the Recovery partition.

What do you mean by migrating? You can just install macOS Catalina on the USB drive and then use Migration Assistant to transfer data from your Mac to the USB with macOS Catalina. Since you are running macOS Mojave, you will need to first install macOS Mojave on the USB. Then, you can update to Catalina.

Good luck!

  • "What do I mean by migrating"? I began with a clean install of Catalina on the external SSD (freshly formatted and encrypted), then (after some experimentation) ran Migration Assistant to copy the content of the internal HDD onto it, in the process learning that a fair amount of the stuff had to be modified to work on Catalina, either because of volume name changes, or because Catalina does not like user content in the root of the load-source drive. Apr 16, 2020 at 15:28
  • Hopefully, by the weekend, I will have a chance to try Safe Mode and First Aid (I may have already tried the latter). I've been a bit busy all week with other projects. The ultimate goal is for the SSD to become the permanent load source, with most of the internal HDD relegated to Time Machine: we've found that external SSDs are typically much faster. Apr 16, 2020 at 15:36
  • You should install macOS Mojave on the SSD like I said and then use Migration Assistant to migrate the data. Then upgrade to Catalina on the USB drive using Install macOS Catalina from the App Store when you are booted on the external drive.
    – Todd
    Apr 20, 2020 at 12:56
  • I may do just that. Assuming a better solution doesn't present itself first, I'll save copies of a few things I had to modify for the external drive's volume name (or for Catalina's inability to connect to a very old Samba server), and then wipe the SSD clean, and start from scratch, this time with the approach that @Todd suggested. Although I'm not immediately clear on how to put Mojave on the external drive first. Apr 28, 2020 at 21:00
  • Get a computer with OS X El Capitan, macOS Sierra, macOS High Sierra, or macOS Mojave and then download "Install macOS Mojave" from the App Store. Then you can use that to install macOS Mojave on the External SSD. If you prefer, you can use macOS Recovery on a computer using macOS Mojave and use the reinstall macOS Mojave option to reinstall macOS on the External SSD. Make sure to Erase the SSD as APFS first.
    – Todd
    Apr 29, 2020 at 14:08

The Catalina updater runs a critical firmware update. The install method you describe has bypassed the firmware update. As suggested elsewhere, install Mojave on external drive, boot from the drive ( holding Option at boot time is my preferred method), and run updater.

There was also a critical firmware update with High Sierra that Apple requires for Mojave. If you managed to bypass that upgrade and went directly from Sierra to Mojave, you may want to ask a new question how to accomplish that. (One would hope the Catalina upgrade will supersede the old firmware, I can't say.)

  • Actually, it looks like it did do the firmware update, as there was a lot going on that didn't involve the external SSD. And at any rate, I'm pretty sure this is factory Mojave: I don't recall doing any OS updates. Apr 28, 2020 at 23:54
  • It did do the Mojave firmware update? Or the Catalina required firmware update which is performed during the Catalina update? If you installed Catalina to an external disk, without upgrading a Mojave installation directly, I wonder if you haven't bypassed the firmware update process. Apr 29, 2020 at 21:09
  • Also, note that a firmware update requires a reboot and a second reboot to activate it. Whether this "double reboot" is noticeable by someone is hard to say. May 4, 2020 at 20:49
  • I very definitely noticed multiple reboots. And it couldn't have been a "Mojave firmware update," as it's a factory Mojave machine. May 7, 2020 at 17:44
  • See my May 7th and May 16th comments under Todd's answer for the latest developments. May 16, 2020 at 17:18

Bottom line, I am abandoning this whole experiment. This Mac will remain on its internal HDD forever, and it will remain on Mojave forever. Period.

I never should have trusted an external device as a load-source. This Mac is too mission-critical. If it were up to me, the INTERNAL load-source would be a mirrored pair of drives that are individually rated for use in human life support applications.

This week, I finally had a chance to try formatting the SSD again, from scratch, and this time doing the OS installation (Mojave, from Recovery Mode) and the migration in one swell foop. And it seemed to work.

At first.

Then, following the migration, and the re-establishment of FileVault on the SSD, it crashed three times in under an hour, and the third time, it refused to reboot until I physically unplugged the SSD, in order to force it back to the internal HDD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .