1

My Macbook Pro Late 2011 (running on Sierra) has suddenly started having the white screen problem and I've tried the following:

  • NVRAM, PRAM and SMC reset (could not get past loading bar after entering my user password)
  • Running in Safe Mode (could not get past loading bar after entering my user password)
  • Running in Single-User Mode (fsck shows no problem with the SSD drive, got white screen after "exit" command)
  • Running in Verbose Mode (got white screen after I was in verbose mode or got white screen after "exit" command)
  • Running in Target Disk Mode (connected with a thunderbolt cable, I was able to login to my account on the second Macbook by choosing the main Macbook's SSD from boot selection menu at the startup on the second Macbook. I copied everything on my main SSD to an external HDD, so erasing the drive would not be a problem. However, the second time I've tried this, I could not get past the loading bar after entering my user password - just like I couldn't on the main Macbook)
  • Running in Target Disk Mode (this time as an external drive, on the second Macbook I got the error "macOS could not fix this hard drive, you can still access files but reformat it asap". So, I thought the SSD on the main Macbook has a problem and it was causing this problem!)

After this, I've erased the main SSD and tried to install a fresh macOS Sierra into the empty SSD. However, I got a white screen in the middle of the installation! (side note; I was installing from a bootable external HDD via USB).

After many tries and fails, somehow I was able to come to the final stages of installation (where you create a user name, password etc.). I entered the information and hit finish, then the computer just froze (the cursor and everything). I could not finish the installation on the main Macbook.

-Bear with me here-

I was not ready to give up, so I put the main Macbook into Target Disk Mode and I finished the installation on the second Macbook. Logged in, could see my fresh desktop.

I hoped it would work just as fine on the main Macbook, but now I cannot even see the user login screen. The only thing I can see is the Apple logo and the progress bar that never finishes loading (because it gets interrupted with a white screen, it fills 3/4 approximately).

So my question folks, does my Macbook Pro Late 2011 have a hardware or software issue? If it is hardware, what could it be? Keep in mind that I do not have anything plugged in or changed any hardware recently.

Thanks for reading, hoping for an answer.

Cheers & stay safe!

UPDATE: I've installed a fresh macos Sierra to an external HDD and plugged it in my main Macbook Pro, selected that drive using Option key and I still can't get past the loading bar with Apple logo (get white screen).

  • 1
    It could be either, but my gut and experience tells me it's hardware. I would start with Apple Diagnostics (Hold D while booting) to see what you can see. It could be the GPU as those models were notorious for GPU issues. It could be the drive or the SATA cable (leaning this way because of Target Disk Mode) and finally software - a re-install would address that. – Allan Apr 2 at 22:34
  • 1
    Most importantly, make sure you backup your data! – Allan Apr 2 at 22:37
  • Apple Diagnostics doesn't seem to work. @Allan, also backed up my data, no worries. I just want to get my Macbook working again... – grains Apr 3 at 13:04
  • Assuming you’re booting off the USB, if you still get that error, you’ve ruled out the drive/SATA cable. You can try using Ultimate Boot CD on that vintage Mac and try running some tests like CPU, GPU, and memory. Also see this answer - very similar. – Allan Apr 3 at 19:23
1

You've tried replacing all the software and the issue still persists, so it sounds like a hardware issue.

RAM is the easiest hardware to test, so I'd suggest running memtest86+ on your Mac for a while to see if it picks up any problems.

| improve this answer | |
  • Ran memtest86, no problems were found. – grains Apr 6 at 18:55
0

So, I've found the solution.

The problem was not about the SSD nor RAM. The dGPU is the problem. As I was doing my research about people having similar issues with 2011 Macbook Pros, I've came across this fix: http://dosdude1.com/gpudisable/

Apparently, the AMD graphics processors that Apple decided to put in 2011 Macbook Pros 15" and 17" are doomed to die and Apple is not repairing them any more (since it means a logic board replacement). So, the easy solution is a software fix. Just follow dosdude1's instructions from the link above and after you disable the dGPU, the computer would boot normally.

Don't forget, it is not a permanent fix. There is a physical chip that you can solder to the main board called Tiresias the GPUkiller (http://www.cmizapper.com/install/tiresias-820-2915.html), but if you don't have soldering skills, my advice would be sticking to the software fix. Keep in mind that dosdude1's fix would work until you reset the SMC/NVRAM (hope you'll never need to do that, but if you do, use dosdude1's fix again).

Hope my answer could help other Macbook Pro 2011 owners, since every devices' dGPUs are doomed to die some day.

Cheers & stay safe out here!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .