I am experiencing an identical problem to the one in: Unable to format internal drive as APFS on 2018 MacBook Pro

However this thread in unanswered and unresolved

My internal drive can format to everything except APFS, I have tried troubleshooting via linux, and simple disk utility. Fsck and first aid both report no problems and this is driving me insane!! help desperately needed!

  • IF you can edit this so it explains how the answer here doesn't work, that might help the quickest. apple.stackexchange.com/a/387218/5472 – bmike Apr 4 '20 at 20:16
  • @bmike I do not have 50 rep and so cannot comment on that post. Am looking for a solution urgently and so reopened. – Guy Torbet Apr 4 '20 at 20:21
  • That's why you should edit this question here to be precisely what you are stuck on and remove all the back story. No one is going to see the wall of text above and likely know how to help. It's too long and they will think you're panicked, not thinking it through and hope you can clarify in a day or three. – bmike Apr 4 '20 at 20:22
  • @bmike simplified it a bit, sorry for the inconvenience I'm new to this! – Guy Torbet Apr 4 '20 at 20:27
  • Without some extra details we can’t help further. Feel free to edit in details if the two answers aren’t helpful and we can revisit opening this for more answers – bmike Dec 1 '20 at 2:31

I do not know if you read my answer to the question you refer to? The command diskutil apfs createcontainer disk0 should have failed. You are suppose to create the container inside a partition (or two partitions where each partition is on a different drive). You specified disk0 which usually is the primary internal drive on a Mac. Maybe you were able to create the container, but being unable to create a volume would not be an unexpected result.

Below are the commands from my other answer.

diskutil eraseDisk JHFS+ dummy GPT disk0
diskutil apfs createContainer disk0s2
Container=$(diskutil info disk0s2 | grep Container)
diskutil apfs addVolume "${Container##* }" APFS myVolume

The first command creates the partitions. The second command create a APFS container in the second partition. The third and fourth commands creates an APFS volume in the APFS container.

  • 1
    Yes I attempted that and replied on the old post. all is fine until I add the volume, in which case I get an error 69624 unable to add APFS Volume to container. imgur.com/a/zXcrjYx – Guy Torbet Apr 7 '20 at 13:31
  • OK, I admit I should have realized the container would not be disk1. Obviously, you figured this out. What I originally suggested was to execute the first two commands, then post the output from the commands diskutil apfs list and gpt -r show /dev/disk0. This would show if space was available for a APFS volume. Also, what is the model/year of your Mac? How are you booting to macOS Recovery? I was wondering if booting to a different version would fix the problem. – David Anderson Apr 7 '20 at 16:10
  • This is on a 2018 MBP 15, I have tried from internet recovery and bootable USB. I have tried your updated commands and they still result in an error 69624, still specifically adding the volume to the container. – Guy Torbet Apr 7 '20 at 17:56

Why not boot to recovery, erase and reinstall?

There is zero need for a command line approach if you have a complicated APFS / CS / diskutil situation and aren't comfortable posting your precise setup and a quick explanation of which one command you need some explanation or help with.

  • I cannot erase to apfs and get error 69624 when diskutil attempts to add the volume. – Guy Torbet Apr 4 '20 at 19:41
  • @show me the disk utility window screen shot that gets you that error? Step 7 of the erase should look like this image - support.apple.com/library/content/dam/edam/applecare/images/… – bmike Apr 4 '20 at 20:20
  • imgur.com/YPhNmAb – Guy Torbet Apr 4 '20 at 20:24
  • any ideas? it is specifically adding the volume to the container – Guy Torbet Apr 4 '20 at 21:27
  • 1
    Well, if you have a container, then post the output from diskutil apfs list. It might also be helpful to post the output from gpt -r show /dev/disk0. – David Anderson Apr 4 '20 at 22:50

Not the answer you're looking for? Browse other questions tagged .