Every time I open my terminal I get

(base) Users-MacBook-Air:~ Uriel$

instead of

Users-MacBook-Air:~ Uriel$

without the (base) line which means that the environment of conda is open. In order to get this, I have to do

conda deactivate

every time in my Terminal and it is annoying because not only I always have to type that but also because every time I open it, I have to wait some seconds because I think is logging conda in

Up in my Terminal what I should only get is the label

user--- -bash ---

but before I get that I see that first appears

Terminal --python<-bash


Terminal --java<-bash


Terminal --R<-bash

etc., until I get the

user--- -bash ---.

Is it because I let conda open? Or something like that? How do I fix this?

Following is the contents of the ~/.bash_profile file:

# Setting PATH for Python 3.6
# The original version is saved in .bash_profile.pysave
export PATH

# Setting PATH for Python 3.8
# The original version is saved in .bash_profile.pysave
export PATH
# added by Anaconda3 2019.10 installer
# >>> conda init >>>
# !! Contents within this block are managed by 'conda init' !!
__conda_setup="$(CONDA_REPORT_ERRORS=false '/Users/user/opt/anaconda3/bin/conda' shell.bash hook 2> /dev/null)"
if [ $? -eq 0 ]; then
    \eval "$__conda_setup"
    if [ -f "/Users/user/opt/anaconda3/etc/profile.d/conda.sh" ]; then
        . "/Users/user/opt/anaconda3/etc/profile.d/conda.sh"
        CONDA_CHANGEPS1=false conda activate base
        \export PATH="/Users/user/opt/anaconda3/bin:$PATH"
unset __conda_setup
# <<< conda init <<<
conda deactivate
  • Welcome to Ask Different :) Kindly share the contents of your .bashrc, .profile and .bash_profile files from your home directory.
    – Nimesh Neema
    Commented Apr 1, 2020 at 6:32
  • 1
    @NimeshNeema could you vote for apple.stackexchange.com/questions/371727/… please ? Just to link both in closure.
    – anki
    Commented Apr 1, 2020 at 6:34
  • @NimeshNeema thanks for the editing. I am new at this. How do I share my .bashrc, .profile and bash_profile? Commented Apr 1, 2020 at 6:52
  • @turddisturb Run the following command in Terminal pbcopy < ~/.bash_profile and paste the content in your question. Repeat the command for all the files (you may or may not have some files on your computer). Mention the name of the file along with the contents.
    – Nimesh Neema
    Commented Apr 1, 2020 at 6:54
  • @NimeshNeema I updated it. I ran the command open ~/.bashrc and open ~/.profile but it said that the files don't exist. Commented Apr 1, 2020 at 7:17

1 Answer 1


It's default behaviour and it is not really problematic. If you deactivate it, the terminal will see default python installation, 2.7. That is troubling if you're using conda for python > 2.7.

If you're troubled by the (base) appearing in the prompt, Run:

open ~/.bash_profile

and add this line at the end

conda deactivate
  • Worked thanks. It still takes a few seconds because it still appears at the top or the terminal all the Terminal --java<-bash, Terminal --R<-bash,etc. Is this normal? Or it shouldn't happen? Commented Apr 1, 2020 at 7:03
  • see the linked questions, apple.stackexchange.com/questions/371727/… option 2
    – anki
    Commented Apr 1, 2020 at 7:04
  • For the Terminal --java<-bash problems, follow Nimesh's instructions and update the question
    – anki
    Commented Apr 1, 2020 at 7:05

Not the answer you're looking for? Browse other questions tagged .