1

I have been fighting with this problem for some days now and I gave up solving it looking for a solution on google.

I have a Macbook Air (late 2010) which had Lion. My gf wanted to pass it on to her cousin, so she cleaned everything, but she was not able to complete the reset for various reasons.. internet not working for password issues and so on.

Now I took over and tried almost everything.. Command + R sends me to internet recovery, to which I also have to "open" my wifi network, since the Mac does not recognize my password for whatever reason. Once I am in, I tried to reinstall Lion following the instructions, but it ends up asking me an Apple ID, which I created, only to end up telling me I am not allowed to download the OS because my Apple ID was never used to purchase anything on the App store yet. Important here maybe is also to say that my girlfriend does not want to use her Apple ID, since she wants to pass it on without her credentials. I am not even sure if she ever purchased anything with her ID as well, since she got the computer from her father, sigh..

So I looked for other options, the bootable USB came next, so I downloaded Sierra from Apple on my pc (funny enough no Apple ID was asked) and I downloaded TransMAC to create a bootable USB drive for Mac. Then I went on to insert the USB and start the Mac holding down the Option/Alt button, but unfortunately it would not give me the option to start from USB, not even asking anything actually. So I am brought back to internet recovery, which does something for some minutes, I suppose, and then takes me back to disk utility.

There I tried to restore the USB stick on the hard disk, but I always get "source is busy" when trying that, although I erased my hard disk and followed the instructions I found for that. Somehow I managed to extract the OS .dmg file on the free space on the USB stick (which is 32 gb), but again I am not able to restore it on the hard disk or anything. On top of that, every time I try to restore/use the image, then the source is not available anymore (semi transparent) and I am forced to restart the whole process, it's either source is busy or another message I can not recall at the moment.

Terminal.. I found the string of command I should write in order to launch the install of Sierra from Terminal, but somehow my session starts with a weird -bash-3.2# prompt and sudo is not recognized as a known command. I guess I am not in the root there, or not sure where the problem is.

I shall also make clear that I am no Mac user and my system administrator memories are 10 years old and obviously need a deep refresh.

So, please, what can I try or where did I do wrong? I am not too solid on the bootable USB creation and why the Mac would not even consider my start + option button held, but transMAC tells me the USB is ready for mac.

Thanks a lot for your help and sorry for the long explanation, but I wanted to to cut out most of the otions I already went through following this forum in the last few days ;)

1

Follow the instructions at What to do before you sell, give away, or trade in your Mac ...there is a link halfway down this page on How to erase a disk for Mac. Yes, at one point you need to put in your girlfriend's or her father's Apple ID, but that's only your permission to install the OS from the App Store (you need an account = Apple ID to do that). The Apple ID you enter at that point does not stay on the system at all, it's only used to get access to the OS installer on the App Store. There are other ways but this is by far the easiest, given your background with Macs. Best regards.

2
  • thanks for the answer, and if I want to upgrade to Sierra now that I am at it? I thought the USB drive way would be the easiest, right? any idea where I stumbled there? thanks! – lenceindo Apr 1 '20 at 13:42
  • Unfortunately the reinstall option is not possible, I tried with the ID of my gf but the apple store says the item is currently unavailable. Not sure if it is the Lion OS unavailable or just the whole service at the moment :( – lenceindo Apr 2 '20 at 1:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .