OSX asks for my user password pretty often -- seemingly whenever it needs to use Keychain. How do I make it stop asking me?

  • 3
    This is a little vague... what specific situations are you being prompted for your password in, in which you feel you shouldn't be? In general, the password prompts are a security feature. I'm not sure if there's a way to disable them globally, but if there is, it's probably not a wise thing to do anyway. Commented Jan 30, 2012 at 4:13
  • Check the relevant keychains in Keychain Access. login does not lock automatically by default. If you changed this setting, you'll need to enter the password whenever you need to access something in it outside the unlock grace period. Commented Jan 30, 2012 at 12:51

1 Answer 1


As you phrased this, it generally occurs because the login password was reset at some point, and now the "login" keychain is protected with a different password than the account as a whole. The other possibility is that the keychain is set to lock automatically. Both issues can be addressed using Keychain Access, which lives in your Utilities folder.

If you do not know the password:

  1. Choose Preferences from the Keychain Access menu.
    Choose Preferences from the Keychain  menu
  2. Click Reset My Default Keychain
    Keychain Preferences window

If you do know the password, but Keychain is auto-locked

  1. Highlight the "login" keychain on the left of the main window.
    login keychain in source list
  2. Choose Change Setting for keychain "login"… from the Edit menu
    edit menu image
  3. Adjust settings as desired. By default, keychain does not lock automatically.
    per-keychain settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .