0

I've transplanted the SSD drive between two identical MacBook Air's - both are 13" Early 2015 models - as one of them had died. Upon moving the SSD from the dead MacBook to the other one, booting the computer presents me with the folder and the question mark icon.

Holding down ⌥ Option on boot only gives me the option for network recovery. I created an installation USB using the same OS that is on the SSD (High Sierra) and booted into it. Here I can see the disk in disk utility and everything appears normal. I ran first aid on the disk and no major errors were found, only a few permission errors were fixed.

When selecting the Startup Disk option, I have the option to choose the SSD however upon reboot it cannot be seen again, only the installation USB is detected. (See below pictures)

Choose Startup Disk Startup Options

How can I get the "new" MacBook Air to boot from the "old" SSD?

If there is anything I missed, please let me know!

| improve this question | | | | |
  • A1466 actually covers 11 models across 3 years. You can double-check using Everymac's Ultimate Mac Lookup – Tetsujin Mar 31 at 11:02
  • 1
    @Tetsujin sorry should have clarified, they're both "MacBook Air (13-inch, Early 2015)" according to their serial numbers also – SteppingHat Mar 31 at 12:45
  • Seeing the physical drive and seeing a bootable partition are two different things - this is what's happening. I would start with resetting the NVRAM. Also, the SSD wasn't encrypted, was it? – Allan Mar 31 at 18:00
  • Also, the next time you're in Recovery, try this command: bless --device /dev/disk0s2 --setBoot --verbose The SSD device id should be disk0 but double check with diskutil list – Allan Mar 31 at 18:03
  • @Allan I've reset the NVRAM with no luck and the drive isn't encrypted. I've tried to bless the drive but it also hasn't seemed to make any difference. Is there any specific output from bless that i should be looking out for? – SteppingHat Apr 1 at 2:33
1

So as it turns out, there was nothing wrong with the SSD or any boot parameters.

The SSD that used to be in the MacBook was running Yosemite, however the one that I was putting into it was running High Sierra.

I solved the issue by putting the original SSD back in, upgrading that to High Sierra then putting the other SSD back in, which was detected immediately and booted instantly.


My best guess is that there may be some form of OS protection built into the system that detects when an older/newer OS is present and acts accordingly. It would be nice to know exactly what's going on there, but for now this has solved my problem.

| improve this answer | | | | |
0

Make sure that the EFI partition isn't damaged. Go to Disk Utility and try running First Aid on the SSD (Usually Disk 0), run First Aid on the Container Disk (If formatted APFS), run First Aid on your Macintosh HD Disk. If the disk was encrypted then first find the disk identifier then go to Terminal, type diskutil apfs listusers <disk identifier>. Then find a user that you know the password to and copy the Cryptographic UUID. Next, type diskutil apfs decryptvolume <disk identifier> -user <Cryptographic UUID>. This should decrypt the disk. Then, try booting to Macintosh HD. If it doesn't work, try erasing everything and reinstalling macOS.

| improve this answer | | | | |
  • Whoa...how do you know that the drive was encrypted? – Allan Mar 31 at 22:43
  • Unfortunately I've already run first aid on the disk and the containers and it hasn't helped. The disk also isn't encrypted, and I can tell because I can navigate through the file system using terminal and can see all the data. – SteppingHat Apr 1 at 1:48
  • Can you boot on any external macOS drives? If you can, then it is an issue with your Internal SSD. If you can't then it is an issue with your Mac. Try disabling Firmware Password or resetting the NVRAM/PRAM. – user368931 Apr 1 at 21:43
  • Can you use the built in Recovery partition? I remember you talking about an Installation Disk. If you can use the Recovery parititon, then that means that your whole SSD isn't corrupted. If you are familiar with terminal, you can try using Single User Mode (Restart then Command + S). – user368931 Apr 1 at 22:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .