2
  • iPhoneXs
  • iOS 13.4 (also affected 13.3.x)
  • Carrier: AT&T
  • e-SIM (no physical SIM)

On a recent trip out of the U.S. I added a 2nd SIM card and a local calling plan (Turkcell) so I could use my phone without incurring roaming charges. All was fine.

PROBLEM: When I returned, I deactivated that plan, and removed the SIM card from the phone. However, the iPhone retained the incorrect phone number formatting on the dialpad screen. See screenshot below for example:

dialpad

This might seem like a frivolous detail, but it actually slows me down when dialing numbers "manually" since it always looks like I've entered the number incorrectly, skipped a digit or added an extra one, etc. I just want to get it back to the correct format.

Once I hit the green Dial button, the number is correctly formatted, so it's just doing this on the pre-dial screen. See below:

dialing

Thing's I've tried:

  • Soft resetting the phone (Vol+, Vol-, then press+hold Power until it reboots)
  • Changing Language under Settings > Language & Region e.g. from English U.S. to something else and then back again
  • Adding / removing additional keyboards
  • Turning Roaming on/off
  • Turning Cellular Data on/off
  • Disabling the cellular line under Settings > Cellular and then re-enabling it
  • Calling AT&T and having them "re-provision" my phone
  • Updating from iOS 13.3 to 13.4

Things I have NOT tried:

  • Going to an Apple Store (they're closed here right now due to COVID-19) 😔
  • Doing a full Backup / Restore of the phone
  • The various "Resets" under Settings > Reset (was afraid to lose my stored passwords/WiFi settings but if anyone thinks that would fix it, I will try...)

Anyone ever see this or know how to fix it?

3 Answers 3

2

I had the extact same issue. I believe this is an issue with the eSim. I had to put a US SIM in and it corrected the issue with the phone numbers displaying wrong when dialing manually.

1
  • I was going to actually post an update - I had previously used a Turkish SIM card while traveling and I guess there was a bug in an earlier iOS (12 or 13, can't remember which version) where even after switching back to US/AT&T it retained the foreign dial pattern - even after the SIM was removed/deactivated. A couple of weeks ago I switched from AT&T to Google Fi (eSIM) and during that activation process, the dial pattern problem finally resolved itself. Not really a good solution, since without a 2nd US-based SIM or eSIM to activate, there is really no way to fix this.
    – luckman212
    Aug 7, 2020 at 21:25
0

I know this is old topic. I just have the same issue and found a solution. it worked for me, you might want to try.

  • Disable the cellular line under Settings
  • Restart iPhone
  • Enable the cellular line under Settings

good luck,

0

I had this exact same issue. I tried all the things the original poster did above too. I even tried Apple support to no avail. After reading a similar article (https://discussions.apple.com/thread/251341824), I think the common thread is the eSIM.

I called T-Mobile and after troubleshooting and trying a few other options, I had them delete/reissue my eSIM. It took a while for them to do this, but it resolved the issue! Hopefully this will help someone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .