6

In macOS Catalina I know that under Finder -> Preferences -> Advanced I can check "Show all filename extensions" and it will do that, but I do not want that. For example, I want to keep hiding all the .app extensions.

However, it used to be that by default, when I saved a file from an application, the Finder would show that file's extensions. Maybe this was a setting I set that I forgot about, or maybe that was the default for the OS, I don't know for sure, but I do know that is the way it worked across all applications.

Now, under Catalina, the default is to hide the file's extension. To get the extension to show, I either need to add it to the filename when saving or save it and then go to the file's Info and uncheck "Hide extension".

Is there a way to make it the system-wide default to save new files with their extensions showing in macOS 10.15 Catalina?

3 Answers 3

8

Like StefsterNYC, I had Show all filename extensions checked in Finder > Preferences > Advanced, and therefore could not see the Hide extension option in save windows pictured in sonderpa's answer.

no extension in filename input, no hide extension option to uncheck

Unchecking Show all filename extensions in Finder > Preferences > Advanced allowed me to see and uncheck the Hide extension option in save windows.

extension in filename input, hide extension option unchecked

Rechecking Show all filename extensions in Finder > Preferences > Advanced hides extensions (in the filename input field) and the Hide extension option in save windows again. This is a bug and should be reported to Apple (my report's Feedback ID: FB9887776).

1
  • 1
    I can confirm the ^^ behavior. Thank you! Apr 7 at 17:40
2

This was annoying me too. Today I found a solution. You can now set save with/without extension in every application. As soon as you get the Save screen you can change this and it will be saved for that application

Save dialog

2
  • 1
    I just have a Hazel rule that watches folders I care about and sets the option on files placed in them. Jan 3 at 16:36
  • genius solution @MarcWilson - that might make the best answer here for someone that doesn't want the all/none setting Apple provides
    – bmike
    Feb 7 at 0:53
1

Mine was way different than this. I had to actually go into Finder Preferences > Advanced and uncheck Show all filename extensions.

While I did do this, the files that were saved in different directories still showed their file extensions which is good and when saving, but the issue went away from duplicating. So that's good.

showing Show all filename extensions unchecked in Finder Preferences Advanced tab

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .