I'm finding that when streaming video or audio from either my iPad 1 or iPhone 4 to my Apple TV 2, it more often than not fails (although it does occasionally work). I'd say 6/10 it fails.


  • Start playing the media
  • Press the AirPlay button (either from within the app or on the task bar)
  • Choose the Apple TV receiver

and after a few seconds it'll revert back to displaying on the local device.

I select the AirPlay option either before the media starts, or during it. It doesn't seem to make a difference.

Some times it'll look as though Apple TV tries to load it, other times it does not.

This happens with any application I use (eg. Safari, Spotify, Downcast).

My setup is as follows:

  • My iPad and iPhone 4 are connected to an Airport Express
  • My Apple TV is wired to a Netgear DG934G (a Sky Broadband router).
  • The Netgear and Airport Express are wired to each other.
  • I also have a laptop running XBMC which is acting as a AirPlay receiver. This is connected wirelessly to the Netgear. This too is flakey in terms of supporting AirPlay.

Is it common for AirPlay to fail this frequently, or do I have problem?


  • Anecdotally, AirPlay is reliable on my network. MacBook Pro, iPhone, iPad and Apple TV2 all connected wirelessly via an Airport Extreme (not the latest model.) I've occassionally added an Airport Express to network (also via wireless) and used it for AirPlay too. Bottom line, it can work, so I'd start trouble shooting your network by testing some "simpler" connections. Good luck!
    – jaberg
    Jan 29, 2012 at 21:29
  • Baring your suggestion in mind of testing simpler connections, I've just changed it so ATV is now on a wireless connection to the Airport Express. So both the sender (iPhone 4) and reciever are on the same network. Still no joy though. Thanks for the suggestion. Jan 29, 2012 at 23:03
  • Hmm.. I just did a reset (menu + down buttons) and it's not failed me yet. We'll see how that works out. Jan 29, 2012 at 23:06

2 Answers 2


No - that is not at all common.

Something is certainly causing the instability so you might need to isolate the potential causes one at a time.

  • network issues (the most likely culprit but by far not the only one)
  • Apple TV needing a restore or perhaps just a reboot.
  • iOS device needing the same (restore or reboot).

Before restoring your iOS device, you might try the other steps first or also you could take your device to another network / Apple TV such as a retail store to test and make sure that's not the cause.

  • I'm ashamed to say that the reboot (menu + down button) did the trick :) It's now working with everything I throw at it, including stuff that has never worked (some stuff worked every now and then, other stuff never worked). I can't believe I thought Apple would release something as dodgy as what I'd been using since I purchased it at Christmas. Much better following the rest! Thanks. Jan 30, 2012 at 23:11
  • It's not embarrassing at all. There is no off button, no reboot switch, so they rarely get a reset using the remote. It's even worse when it needs a real restore since most Apple users don't yet have the correct USB to Micro-USB cables to do an unpowered restore from iTunes.
    – bmike
    Jan 30, 2012 at 23:18
  • I had a very similar issue with my brand spankin’ new AppleTV (3rd Gen). Rebooting the device did the trick for me, too. Rebooting AppleTV 2nd & 4rd Gen
    – roosto
    Apr 11, 2012 at 12:37

I've had similar airplay flakiness. I can usually fix the issue by toggling AirPlay off and on, but I've also had to reset the Apple TV.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .