3

Would like to get some assistance: Device: Macbook Pro 2010 13"

Previously I was successfully install windows by manually create partition, format partition to hybrid GPT/MBR by following a guide. And windows working fine, everything normal until one day I am thinking about install linux so I can have complete 3 OS on mac. And I just carelessly install it and linux installation failed, microsoft partition got affected and OS gone. So I delete partition and now MacOs own fully the disk and partition.

The issue now, I am trying to install windows again and its all working until EFI boot on flashdisk done. When turn on mac and hold option button and the "EFI BOOT" appear as installing windows. When we click or press enter, thats it. Its freezing for a moment and will reboot again.

Anyone can help to advise on what to do? I have tried to repair disk on MacOs recovery. But nothing seems work. If anyone have solution or advise I will be open. Thank you in advance.

Instruction I followed previously which was successfully installed windows without bootcamp: https://bit.ly/2JiffBl

I wish Mr David Anderson >> https://apple.meta.stackexchange.com/users/107222/david-anderson can have a look as well and advise what to do as previously I followed his instruction and all is well until I am carelessly tried to install linux without further research.

Will clean install High Sierra OS fix the issue??

Partition layout from gdisk

dn1122$ sudo gdisk /dev/disk0
GPT fdisk (gdisk) version 1.0.5

Warning: Devices opened with shared lock will not have their
partition table automatically reloaded!
Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): r

Recovery/transformation command (? for help): o

Disk size is 468862128 sectors (223.6 GiB)
MBR disk identifier: 0x98F8FE8A
MBR partitions:

Number  Boot  Start Sector   End Sector   Status      Code
   1                     1    468862127   primary     0xEE

Recovery/transformation command (? for help): p
Disk /dev/disk0: 468862128 sectors, 223.6 GiB
Sector size (logical): 512 bytes
Disk identifier (GUID): 847C8A90-5D1F-4055-8ADA-1A6C5D7783F8
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 34, last usable sector is 468862094
Partitions will be aligned on 8-sector boundaries
Total free space is 13 sectors (6.5 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1              40          409639   200.0 MiB   EF00  EFI System Partition
   2          409640       468862087   223.4 GiB   AF0A
8
  • @lx07 Thank you sir for advising and I will try. So may I know what cause the bootloader wont let me access the windows installer? Coz been trying to research online for days and some say if its iMac it have relation with the graphic cards or something. But since this is macbook pro I dont think its the case, right? Big thanks as I am helpless so any kind of advise very precious to me. Mar 28 '20 at 15:10
  • @lx07 I have print information and added in the thread for further information and situation. TQ Mar 28 '20 at 16:26
  • @lx07 I think after trying to delete partition, reinstall MacOs its back to normal. The issue now no matter what I tried like doing "first aid" in the recovery mode. Will not fix the boot to start windows installation. Its just freeze without processing anything. Will paste the 'p' here. Mar 28 '20 at 20:25
  • Can you please the solution as an answer below?
    – nohillside
    Mar 30 '20 at 18:11
  • @nohillside I dont really understand sir. Mind to explain what did you asked? Mar 31 '20 at 19:06
1

After trying and search solutions for days with getting no answer I finally resolved it myself by:

Backup macOS using CCC to another harddisk

Also need to make sure regarding the format of drive since I was unable to use the exFat format and need another solution to make it readable in my MBP OS High Sierra. So, I decided to continue follow the instruction but with FAT32 format of USB and partition. For now I successfully have macOS, Windows 10 and Linux on my Mac and mission complete.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .