0

Recently I've encountered a problem, and quite frankly, of course it had to be one of those cases where nothing absolutely helps.

It started around a couple weeks ago, the system was getting random freezes, usually not long after startup, so I decided that maybe it's the time to do a clean reinstall of the system. Soon after which, I realized that my USB ports aren't working whenever I connect anything.

I tried resetting PRAM and SMC, multiple times, still nothing. The computer still freezes for a couple minutes (Touch Bar included), I can only move the cursor and click on stuff but everything is unresponsive until the freeze is gone.

Before you say that maybe my USB ports are fried or something, note that I have a Bootcamp partition, where everything works perfectly, USBs are fine, no freezes, everything works as it should, but not in MacOS. Even in Startup Manager I can move my external mouse, but as soon as system boots, it's unresponsive. If I keep using the system after one of it's freezes, chances are the connected mouse/keyboard will start working, as if it takes it a couple minutes to realize that something's connected.

It would've been much easier to assume that maybe the ports are bent or something but then in that case nothing would've worked in Bootcamp.

Specs: MBP 15' 2016, Mojave 10.14.6 (I tried updating to Catalina, no changes, so I rolled back since I don't like Catalina anyways)

  • Try booting in Safe Mode (Hold Shift while booting). Let's see if you have any 3rd party apps or kexts causing some issues. – Allan Mar 27 at 17:26
  • I tried that earlier today, there's multiple errors every time I try to open anything, or on usb disconnect, but i'm not sure if it's anything unusual. One thing that comes to mind though: During a freeze, if I try to open any app I get this line in the console app: mach error 0x10000004: (ipc/send) timed out. The error is caused by windowserver. I don't know if it helps, but this is what I noticed. And yes, the problems still persist in Safe Mode. – asertym Mar 27 at 18:42
  • mach error has to do with the kernel. I would try installing a fresh copy of macOS to a USB drive (a cheap 32GB flash stick is fine as it's for testing), boot from that and see if the issue goes away. If it does, it's time to start planning a clean install on your primary drive. – Allan Mar 27 at 18:53
  • A clean install is what I already did twice. Once when I wiped everything and flashing Catalina (3-4 days ago), and once yesterday when I rolled back to Mojave. I even used different USB sticks. One thing that bugs me is that there's basically no way (at least I couldn't find any) to wipe SMC from terminal or something, it's done only with the thingy with the power button, and I can't get a read on it if it is done correctly or not. – asertym Mar 27 at 19:04
  • The SMC only controls power and fans, resetting it won't do anything with the OS kernel; neither will NVRAM. Have you tried Apple Diagnostics (Hold D while booting)? – Allan Mar 27 at 20:04

You must log in to answer this question.

Browse other questions tagged .