0

After some Catalina update recently, my 2013 Mac Pro, upon startup, immediately shows the login screen before actually booting up.

By this, I mean that TeamViewer, and other background service are not available until you login once... This makes it extremely frustrating when working remotely to my Mac because I cannot risk rebooting it, otherwise I have to go physically log into it in order for TeamViewer to fire up.

This was not the case for the past 7 years I have been using Macs.

Is there any way to turn off this delayed-load nonsense? I looked everywhere in preferences and Google'd away but either I am not googling the right terms or no one's noticed.

My PCs still work fine after a reboot, FTP, RDP, TeamViewer, IIS all work upon booting a PC on Win10 without having to log in. But, of course, not Apple...

  • Firmware password or actual login screen? support.apple.com/HT204156 – Tetsujin Mar 27 at 12:52
  • I guess your complaint has something to do with why my MBP with Catalina gets to the login screen significantly quicker than my iMac with High Sierra but then the rest takes noticeably longer on the MBP than on my iMac (and also longer than the MBP gets to the login screen itself) after I enter the password. – Alper Mar 27 at 13:36
  • Did this happen after updating from Mojave to Catalina, or at a subsequent Catalina upgrade? – benwiggy Mar 27 at 16:20
  • @Tetsujin actual login screen subsequent update I think it is because File Vault is turned on as in the next response below – Beau D'Amore Apr 13 at 18:14
3

If you've turned on Disk Encryption, then you might get the login from a small boot partition, which then boots the 'real' system after you've authenticated the unencryption with your password.

Alternatively, it may be that Catalina's increased security is more cautious about how third-party software launches at this stage.

If you have just updated to Catalina, then you will need to check that your apps are compatible with Catalina. You may need new versions.

The other option, if your Mac is located in a secure location, is to turn on auto-login in System Preferences > Users & Groups > Login Options.

| improve this answer | |
  • 1
    Per this answer, I checked to see if my FileVault was turned on and it was. I turned it off and the boot time increased noticeably while the login time decreased. The ratio of boot time to login time on my Catalina MBP is now close to the same ratio on my High Sierra iMac. Thx – Alper Mar 27 at 17:14
  • that may be the case,,, I will try turning it off. Makes sense too not to be able to load until unencrypted – Beau D'Amore Mar 27 at 19:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .