3

I have just upgraded several hard drives on our Synology, and now have 2 bare metal drives of smaller capacity (6TB) that I'd like to reuse on my Mac for other purposes. However I can't seem to get them reformatted for use with the Mac: I am only able to reclaim 1.6TB of the original 6TB (WD Red drive)

Here is how they show up initially:

/dev/disk9 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.6 TB     disk9
   1:                 Linux_RAID                         2.6 GB     disk9s1
   2:                 Linux_RAID                         2.1 GB     disk9s2

This adds up to about 6TB, and makes sense to see the Linux_RAID partition types given that I pulled these from Synology.

However after reformatting using Disk Utility, I only see a 1.6TB drive, which is confirmed when I do a diskutil list:

/dev/disk9 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.6 TB     disk9
   1:                        EFI EFI                     209.7 MB   disk9s1
   2:                  Apple_HFS Untitled                1.6 TB     disk9s2

I've tried various combinations of reformatting from the command line, as well [this question] (including diskutil eraseDisk), to no avail. I always seem to end up with a single 1.6TB partition.

Any suggestions on how to fully wipe and reformat the drive to get access to the full capacity?

EDIT: trying to reclaim the partition space did not work either (note that after a reboot, the disk in question is now disk5:

➜  ~ diskutil partitionDisk disk5 1 GPT HFS+ MacintoshHD 100%
Started partitioning on disk5
Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk5s2 as Mac OS Extended with name MacintoshHD
Initialized /dev/rdisk5s2 as a 1 TB case-insensitive HFS Plus volume
Mounting disk
Finished partitioning on disk5
/dev/disk5 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.6 TB     disk5
   1:                        EFI EFI                     209.7 MB   disk5s1
   2:                  Apple_HFS MacintoshHD             1.6 TB     disk5s2

EDIT2: getting details on the disk in question:

➜  ~ system_profiler SPStorageDataType | egrep disk5 -B 10 -A 10
    MacintoshHD:

      Free: 1.6 TB (1,602,103,631,872 bytes)
      Capacity: 1.6 TB (1,602,784,641,024 bytes)
      Mount Point: /Volumes/MacintoshHD
      File System: HFS+
      Writable: Yes
      Ignore Ownership: Yes
      BSD Name: disk5s2
      Volume UUID: 96706824-36D6-37F5-BEC0-E8D7BAA06E9B
      Physical Drive:
          Device Name: External
          Media Name: Generic External Media
          Protocol: USB
          Internal: No
          Partition Map Type: GPT (GUID Partition Table)

  • Try partitioning the disk first – Allan Mar 27 at 6:50
  • Can you clarify @Allan? If I open Disk Utility it gives me the same view: choosing the Partition tab shows only a single partition of 1.6TB, and there doesn't seem to be an option to increase the size of that partition or delete it. Is there a different way of repartitioning the drive? – Ramon Mar 28 at 16:13
  • I'm going to post as an "answer" but edit it as we work through the issue...Much easier than doing in comments. So, see below. – Allan Mar 28 at 19:12
  • 1
    The convenient thing is I just upgraded my Synology unit so I have two drive I need to reclaim as well. I'll work through this with you. – Allan Mar 28 at 19:16
  • How does your first Terminal output „add up to 6 TB“? disk9 shows as 1.6 TB there. Which specific disk model is it? – nohillside Mar 28 at 19:34
2

My (maybe educated) guess:

Your docking station (StarTech SATADOCK22UE) has a useless/faulty/old USB Bridge chipset firmware and you are hit by some double 2.2 TB barrier (=32bit block addressing error).

Depending on the firmware of the WD60EFRX it has a size of 6000527425536 B - 6001424400384 B (ref).

The 2 x 2.2 TB gpt barrier is 4398046511104 B. Disk size - 2 x 2.2 TB gpt barrier = ~1.6 TB!

Depending on the firmware and the real size of the disk you will only see ~1.6 TB in macOS.


Solution: get another external case and mount the 6 TB drive in there!

| improve this answer | |
  • Thanks @klanomath. I had not considered this, but the drive is ~5 years old, so this seems plausible. I will see if I can find another external case to test with – Ramon Mar 28 at 22:48
  • 1
    @Ramon This is no problem of the hard drive itself but the SATA2USB chip (firmware) of the docking station (which seems to be pretty old (2008 or even older)). Officially this docking station supports drives up to 4 TB! – klanomath Mar 28 at 22:52
  • Just got my dock and preliminary test with a single drive looks good. Will year this weekend and confirm – Ramon Apr 4 at 2:07
  • Confirmed. I purchased a Wavlink X-MAN WL-ST336A Dual Drive dock with specs that claimed support up to 10TB drives, and it seems to be working well. Drives initially showed up at the same low 1.6TB capacity but when Disk Utility reformatted them they showed up with the full 6TB of space available. Thank you @klanomath! And @Allan for your help up front – Ramon Apr 4 at 18:25
1

I ran into the mysterious number 1.6 TB many times recently when trying to use a WD Blue 6 TB drive in various old FireWire enclosures I was hoping to re-use.

I tried about four enclosures, and Disk Utility reported a Volume capacity of 1.6 TB (actually 1,603,128,614,912 bytes, for one where I made detailed notes) in all except one enclosure, which correctly reported 6 TB and I'm now semi-happily using.

The best explanation I found for this was here: https://forums.tomshardware.com/threads/4-0tb-gpt-wd-hard-drive-only-showing-as-1-6tb.1867476/#post-12966585

I'll try and repeat that explanation but in my words for your situation.

@klanomath found a post reporting some numbers from several WD60EFRX drives. The number of sectors reported there for each drive varies slightly. Let's go with 11721045168.

In hex, that number is 0x2,BAA0,F4B0.

Each sector on the drive stores 512 bytes. So the total capacity is 0x2,BAA0,F4B0 sectors x 512 bytes = 6 TB capacity. (By the way, I'm using the Soulver app to make it easier to do these calculations, where I'm typing eg "11721045168 x 512 bytes in TB".)

But I agree with @klanomath's guess - I think your StarTech dock uses a 32 bit value (which can represent integers from 0x0000,0000 to 0xFFFF,FFFF) for sector addresses, truncating the highest addressable sector location from 0x2,BAA0,F4B0 down to 0xBAA0,F4B0.

So via that dock, the total capacity is limited to 0xBAA0,F4B0 sectors x 512 bytes = 1.6 TB.

I'd suggest trying a different dock / enclosure.

And if anyone out there knows of a cheaply available FireWire enclosure that allows the full use of a 6 TB drive, I'd like to hear about it!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .