0

My adapter cable was frayed(close to the adapter side), sometimes it wouldn't charge. So I was trying to fix it. I didn't buy a new cable for replacement, instead I cut the original one and soldered on the circuit board.

But after I repaired it, I connected both sides of the adapter to my MacBook Air and to the power socket see if it worked. I saw the indicator lights up and then turns off immediately. After few times plugged and unplugged, I twice got a successful charge connection; the indicator turned green and then turns orange but it won't last longer than 5 minutes. After a while the indicator will turn off again. These two charges got my MacBook 13% power.

I measured the the T connector positive pins(Pin2/4); sometimes I got 0.8V, sometimes it showed 0.5v, I also measured the backside of circuit with multi-meter(yellow and red circle); the voltage showed was 110VDC. I think this adapter probably still working just don't know where I did it wrong.

Please give me some advice on what to do next to get this working.

03/26 Thanks for you guys reply. I was trying to measure voltage by the pin in the green circle, I got 55VDC, but suddenly there was a spark and then the voltage here were all gone, so I checked from the top and saw 3 SMD resistors next to this chip(green circle) were burned... enter image description here I am thinking to replace them because it still recognizable. But except that, I don't see any blown capacitor that might cause no charging. Would someone please share some advice?

New contributor
Nick Yeh is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • I have successfully done what you did - shortening and soldering... However mine worked in all cases bar one where the damage due to prior shorting had "killed" the supply so you may be unlucky. – Solar Mike 2 days ago
  • Thank you for the reply Mike, after teared down some components I not only saw 3 resistors but also one SMD capacitor blown, one of the resistor is not recognizable and I don't know the value of capacitor either. so I think the only thing I can do is let it go... – Nick Yeh yesterday
1

You’re getting the wrong voltage. You should be seeing 3V not .5V. Once connected to the Mac, it will sense the 3V then “request” the full 18V.

What you measured was the incoming power of the mains so you “know” that it’s getting AC in. The problem lots on the DC side of things (after the rectifier) where something has gone bad.

These voltages are listed on Pinoutguide.com and on Wikipedia (6.86V for MagSafe and 3V for MagSafe 2)

What’s wrong specifically? You could have a blown capacitor, resistor or even an IC. You would need the schematics to see which line is sending the 3V and then make the diagnosis and repair. My thoughts are that something shorted with the damaged wire before you embarked on the repair.

It’s probably safer and cheaper to just replace charger and be done with it.

  • Well, I was wrong...sort of. I had to look this info up since I was doing it from memory. It's 3V for MagSafe 2 and 6.86V for MagSafe 1. Either way, it's definitely not .5V – Allan 2 days ago
  • 1
    Curious, how are you doing electronic diagnosis without having reference values to compare to? How do you know what you’re measuring is correct? – Allan 2 days ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .