2

I am using MacBook Pro 2019 with Touch Bar and macOS Catalina 10.15.3. I have installed Amazon WorkSpaces 3.0.4 which I use to connect to Windows.

My Function keys are not getting passed on to my Windows.

How can I solve this issue?

Update 1:

Below are my keyboard settings.

enter image description here

Function keys that I have tried.

  • F11: Shows desktop on Mac
  • F5: In IE / Google Chrome does not refresh the page. It actually does nothing.
  • F4: In Outlook email message does not open the Find dialog. It actually does nothing.
  • 1
    The question seems on-topic to me. It's about using software on a Mac, it should be reproducible and therefore applicable to a broader audience, and is especially timely right now as many people start to use Amazon WorkSpace. – Nic Mar 25 at 22:52
  • This question seems perfectly fine, on topic, clear and nothing is needed to answer it. You could add lots of detail, but only if no one answers in a week or two. Sometimes simple is best. +1 by me – bmike Mar 25 at 23:24
  • 1
    @Nic: I have updated question with additional details. – Naveen 2 days ago
1

I played around with the Keyboard settings and found a workaround. In the Keyboard settings, set the "Touch bar shows" to "F1, F2, etc. Keys". After this setting, my function keys are being recognized in Amazon WorkSpaces. Although it does not recognize F11 as it still shows desktop on Mac. You also lose firect access to App Controls.

enter image description here

0

On macOS the function keys are media keys so if a piece of software doesn’t know that holding the function modifier down make a function key function, choose the keyboard settings and enable the check

  • F1, F2, etc. keys as standard function keys.

enter image description here

  • I have MacBook Pro with touch bar. In my keyboard settings I do not see the option of "Use F1, F2, etc. keys as standard function keys". I have updated my question with screenshot of my keyboard settings. – Naveen 2 days ago
0

Function keys work properly for me in Amazon WorkSpaces. I'm using a 2015 MacBook Pro with real physical function keys (no touch bar). I have this option enabled in Keyboard preferences: Use F1, F2, etc. keys as standard function keys.

Use F1, F2, etc. keys as standard function keys

The F5 key works for me to refresh the page in Internet Explorer.

Although I did notice that I wasn't able to use F11 to make Internet Explorer go into full screen mode until after I had disabled the Show Desktop global keyboard shortcut. Here's how I did that:

  1. Open the macOS Keyboard preferences
  2. Switch to the Shortcuts tab
  3. Select the Mission Control category
  4. Un-check Show Desktop, or change the shortcut to something other than F11
  • I have MacBook Pro with touch bar. In my keyboard settings I do not see the option of "Use F1, F2, etc. keys as standard function keys". I have updated my question with screenshot of my keyboard settings. – Naveen 2 days ago
  • @Naveen Okay thanks. I don't have a touch-bar Mac to test with, so hopefully somebody else can provide a better answer with your additional details. – Nic 2 days ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .