I have an older Macbook, specifically this model, and when I am upgrading the standard 1GB that it came with. I bought DDR2 667 PNY Memory - 2 X 2GB. According to those specs, my unit can manage 4GB. I called Apple just to verify and they told me the same thing.

When I put both sticks into the unit, the machine doesn't boot up.

When I take out one, and put in the old 512MB, it boots up fine and when I get into OS X it tells me I have 2.5GB of RAM (which is right).

I have tried both sticks in both slots (all the possible combinations with the two original 512MB sticks). All combinations work (i.e. 2GB A with 512MB A, 2GB A with 512MB B, 2GB B & 512MB A and 2GB B & 512MB B), except with the 2 x 2GB.

Why is that?

I can't remember with certainty, but I think just the 2GB stick alone (with nothing in the other slot) does NOT work.

I am running memtest now on one of the sticks, to see if there is anything wrong with the actual sticks, so will update this once I have those results (could be a few hours though).

Any thoughts on what may be causing this and how I can fix it?

P.S. The PNY sticks are brand new.

  • your link to the Macbook model is broken.
    – Stu Wilson
    Commented Jan 28, 2012 at 15:17
  • 1
    Just tried it again and it works for me. But basically it is the 2008 white model. Not the aluminium version. Commented Jan 29, 2012 at 1:15
  • 1
    I have the exact same issue BTW.
    – Ben
    Commented Aug 14, 2012 at 21:03

6 Answers 6


This is down to a limitation in some memory controllers and how they handle memory sticks with different memory characteristics (also add into the fact that you have no control over these settings in EFI as you might have in a non-EFI BIOS)

When you put both new sticks in, the memory controller is trying to set up the memory according to the specs advised by the PNY SODIMMs, however it is having problems with that configuration and fails to initialise the memory.

When you put in a stick of the older RAM, it changes the configuration to use the slower RAM's settings and the second stick of RAM is actually running at the slower speeds and timings of the old RAM and these are invariably "slower" and more conservative than those the PNY sticks can run at.

The other posters are correct, the only solution is to get different RAM and try those. I would also advise to use a more reputable brand, the cost differences are minimal and the warranties are better.

  • I thought PNY was 'relatively reputable'. Guess Kingston or Corsair is more appropriate? Commented Jan 29, 2012 at 2:36

It's just a problem with particular memory. Maybe its timings are different than your system expects.

You should just swap it for another DDR2-667 SODIMM. I can't find a somehow full list of mac compatible memory so just try to search if memory you are going to swap with has any positive feedback on the topic.


I have seen this many times, it just happens. The chips are most likely fine in another machine but not yours.

Return the modules and request a refund/exchange.

Try another brand.

If it happens again with exchanged/different brand RAM then your machine could be faulty. If it's an out of warranty system it would be an expensive repair.



If you follow that link it will bring you to Crucial which can run a client that will tell you all the compatible RAM for your Mac. Don't know if it helps though.


Too late for sure. But it could help. Try to update SMC following that link according to your mb model.


It's true older MacBook like my 2.1 can only address 3GB of RAM. Personally I have installed 2x2GB Kingston DDR2 667MHZ SODIMM without any issue. It's running quite fast. Although the computer reports having 4GB, the activities monitor only says 3GB are able to be used. But having 2 identical matching RAM is still better than having a 2GB and 1GB. The price of memory is quite low so having 1GB of 'wasted' RAM is no big deal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .