2

A couple hours ago, my faithful 2011 27" iMac suddenly locked up hard. Only way to bail out was a hard shutdown (hold power for 5 seconds). I did that, and tried to reboot again to no avail. No signs of life at all on pressing the power button. No fans, no beep, nothing.

I unplugged, waited 15 seconds (pressing power during that time just to make sure all juice was drained) and plugged back in. Still no signs of life at all.

I read about someone else having a similar problem and taking out and replacing the RAM fixed it. So I pulled all the modules and tried to power up and see if I'd get any beeps or signs of life. Nothing.

I put the RAM back in, still nothing. Unplugged every single peripheral (Thunderbolt and USB), nothing. Swapped the power cord, nothing.

I'm at a total loss. Anyone have any ideas on why my machine just mysteriously died? Any ideas what else I can try, to bring it back?

5
  • 4
    Don’t shoot me but have you checked the supply and cable?
    – Solar Mike
    Mar 25, 2020 at 8:11
  • 2
    I also have a mid 2011 27" iMac which I am using on a daily basis and quite happy with. You seem to have run into a power supply issue and I hope it is an external one as @Solar Mike pointed out. Hope you fix it quickly. Pls let us know how it goes.
    – Alper
    Mar 25, 2020 at 9:19
  • @SolarMike cable yes, supply (if you mean the computer's PSU) no. If you mean supply at the outlet, yes that is most definitely fine.
    – JVC
    Mar 25, 2020 at 14:33
  • @Alper would a PSU dying manifest this way though? It just crashed (beachball) so I shut it down and POOF that was it. It did not actually turn off in the middle of things, which I've had happen before on PCs and is more what I'd expect from a PSU fail.
    – JVC
    Mar 25, 2020 at 14:34
  • 1
    @JVC I was trying to sort one once and between testing the cable then moving on to the psu someone unplugged it from the wall - cost me some time :) guess how pleased I was...
    – Solar Mike
    Mar 25, 2020 at 14:47

1 Answer 1

3

EDIT 2: Very strange addendum here. This issue began again a few weeks after posting this answer. BUT, I just discovered that while I have inconsistent problems manually getting the iMac to boot, a scheduled startup works perfectly fine, every time. Go figure!

So this is totally weird and I can't explain it but...

Unplugged the mac before I went to bed last night. Came in this morning and tried firing it up before I remembered it was unplugged. Spoiler alert - it didn't boot.

Remembered about an hour later that it was unplugged. Plugged it back in and just like that, normal boot!

Plugged all my peripherals back in and it's like nothing ever went wrong. I have absolutely no idea whatsoever what actually happened but, I'm back up & running.

So if by chance you're in my same boat, try letting it sit completely unplugged overnight and see if you have a similarly miraculous solution appear.

EDIT: Some additional information I just figured out over a month later that is related to this:

Shortly after "solving" this issue originally, I realized my UPS (Uninterruptible Power Supply) was crapping out and no longer holding a charge. I suspected this was related to my problems so I ordered replacement batteries, swapped them out, and all has been good. Until this morning.

I woke up and once again, my machine was in a hosed state. Wouldn't power up at all, no matter what I did. This time even letting it sit several hours unplugged, changed nothing.

Finally out of desperation, I decided to unplug from the UPS (which was still running and showing 100% battery) and plug into the wall directly. Immediately, the Mac booted up fine. No problems at all.

I shut down, plugged back into the UPS, and... nothing. No boot, at all. So I shut off the UPS, waited 5-10 seconds, and turned it back on. Just like that, the Mac booted up again fine!

Moral of the story here is, if your Mac won't boot and it's plugged into a UPS, try power cycling the UPS itself. Might save you a lot of headache.

10
  • 1
    15 seconds is usually too short to wait for capacitor discharge and for the fuse to reset. Normally, you give it 30 seconds to a minute. But glad you got it sorted!
    – Allan
    Mar 25, 2020 at 20:06
  • yeah I actually tried 90 seconds as well, holding the power button down the whole time... didn't work. Some sort of black magic going on here no doubt. lol
    – JVC
    Mar 25, 2020 at 20:07
  • 1
    Oh...I meant unplugged for 30 to 60 seconds. You shouldn’t hold it for that long. That was based on industry standard - maybe Mac is one of those that needs a 15 min (or more) hiatus.
    – Allan
    Mar 25, 2020 at 20:11
  • 1
    Just out of curiosity, do you have it on a UPS (not just a surge protector). Brown outs can cause issues as well.
    – Allan
    Mar 25, 2020 at 20:15
  • 1
    Cool. Good diagnostic procedures though! “Sleeping on it” is sometimes the best strategy!
    – Allan
    Mar 25, 2020 at 20:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .