0

I have an old iPad running on iOS 9. The iPad is used for "simple tasks" like watching Netflix. Up to today, I was able to install older versions of Apps as long as I had already purchased them (similar to these instructions), but now I am no longer able to do so. Instead I just get the message that the device is too old for the app.

I tried the Netflix app and the Youtube app, as those are the only previous purchases on the iTunes account not currently installed. New purchases work fine, as long as these actually support iOS 9.

Has something changed in the App Store approving previous purchases with old versions, or is it the case that Netflix and Youtube both pulled older versions and I coincidentally am stuck on both?

1

When trying to download the App from search results, the download fails. However when browsing the "Purchased" section, I am able to download the older version.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .