A couple days ago my MacBook, an early 2016, 12-inch, Retina model had a hard freeze, rainbow wheel and screen frozen.

After a forced restart holding down the power button I was able to get to the login screen but my password would not work.

After additional restarts I was greeted with the Flashing ? Folder icon for no startup disk.

I tried it number of times, making sure I was not doing caps lock or anything of that nature. I was eventually able to get it running by installing macOS Mojave to an external drive however...

The internal hard drive does now show up in anything: Disk Utility, diskutil list,System Information App > Storage, Recovery Mode / Only Recovery Mode etc.

The HDD on these models is soldered to the board so I cannot remove it for further testing.

Does this mean that my SSD is totally done for? Are there any other ways I can access it and test it?

Below is my output from diskutil and some screen shots from Recovery Mode

EDIT: The 319GB Drive is my external WD Hard Drive I am booted from, the CD sized drive is one of those built in partition on an external drive where the recovery software they bundle is stored.

The Internal Drive is not showing up at all and should be 512 MB.

Find below the system_profiler terminal output:

users-MacBook:~ user$ system_profiler SPStorageDataType

    WD SmartWare:

      Available: Zero KB
      Capacity: 160.6 MB (160,604,160 bytes)
      Mount Point: /Volumes/WD SmartWare
      File System: HFS+
      Writable: No
      Ignore Ownership: Yes
      BSD Name: disk1s0s2
      Volume UUID: CF13F5E3-21B4-391A-8E7A-61487FE0364D
      Physical Drive:
          Device Name: Virtual CD 070A
          Media Name: WD Virtual CD 070A Media
          Protocol: USB
          Internal: No
          Partition Map Type: Unknown


      Available: 263.79 GB (263,788,789,760 bytes)
      Capacity: 319.16 GB (319,160,279,040 bytes)
      Mount Point: /
      File System: APFS
      Writable: Yes
      Ignore Ownership: No
      BSD Name: disk2s1
      Volume UUID: E37C64A0-D133-4FAF-9942-22DF646B6E92
      Physical Drive:
          Device Name: My Passport 070A
          Media Name: AppleAPFSMedia
          Protocol: USB
          Internal: No
          Partition Map Type: Unknown

DiskUtility diskutil diskutil2 diskutil3 startup

/dev/disk0 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *319.4 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk2         319.2 GB   disk0s2

/dev/disk1 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:        CD_partition_scheme                        *804.4 MB   disk1
   1:     Apple_partition_scheme                         700.4 MB   disk1s0
   2:        Apple_partition_map                         32.3 KB    disk1s0s1
   3:                  Apple_HFS WD SmartWare            160.6 MB   disk1s0s2

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +319.2 GB   disk2
                                 Physical Store disk0s2
   1:                APFS Volume Untitled                44.9 GB    disk2s1
   2:                APFS Volume Preboot                 44.7 MB    disk2s2
   3:                APFS Volume Recovery                510.4 MB   disk2s3
   4:                APFS Volume VM                      4.3 GB     disk2s4
  • Something's definately up with your drive because 319GB is an awfully odd size; the 2016 12" MB came with 256 or 512GB. Is Bootcamp installed by chance? Also try this (I've never done this in recovery so let's see if it works)... Issue the command system_profiler SPStorageDataType and post your results. Let's see what the system sees with respect to storage devices.
    – Allan
    Commented Mar 21, 2020 at 0:07
  • I've seen (spinning) drives go bad and report strange capacity numbers that have no basis in reality. I would guess that the SSD in this Mac died, but if someone else comes up with more things to try, it's probably worth it. Start with @allan 's suggestion Commented Mar 21, 2020 at 0:12
  • @Allan - Sorry that was unclear of me, the 319 is my 350GB WD External I am booted from. The internal drive is 512GB. I will edit the post for this.
    – ian
    Commented Mar 21, 2020 at 15:31
  • @Steven Chambers - Sorry to be unclear, the 319 Is my WD External, Not a strange size for the internal drive, the Internal is not showing up at all.
    – ian
    Commented Mar 21, 2020 at 15:32
  • Added system_profiler output.
    – ian
    Commented Mar 21, 2020 at 15:37

1 Answer 1


Yesterday I had the same problem and solved it by creating a bootable USB with Mac OS Mojave.

Next you need to power on the Mac while holding Option, then select "boot from USB". Wait and open Disk Utility and the SSD will be there.

This solution worked for me. I think disk utility in network recovery is limited or is a old version without support.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .