8

I have this very strange problem that dictation is not working on my laptop when its lid is closed and it is connected to an external monitor (Cinema display). It does work fine when I use the laptop standalone.

Also, when I go to System Preferences / Keyboard / Dictation, I can see the microphone showing input (level meter does up and down when I speak). It does not matter whether the audio input under the microphone is on "Display audio" or "Automatic", when I open any other app and start dictating, the little microphone does not show any sign of activity (i.e., input).

Even more funny is that Siri on the laptop works fine, even with closed laptop lid, i.e., it does recognize my speech commands.

I think, the real problem is that, somehow, with display microphone, something is blocking the audio input on the way to the dictation software.

Of course, I have googled and tried a few things (reboot, switch audio, etc.), to no avail. But I haven't found a problem description on the web that matches the problems symptoms I am experiencing.

Does anyone have an idea?

PS: I recently upgraded to Catalina (10.15.3). Before, under Mojave, dictation worked.

  • does it work if you connect, for example, AirPods to your MacBook and set AirPods as the sound input? – Anton K Jun 21 at 19:39
  • Good Question. No, it doesn't work. No matter , which input source I choose in System Audio Preferences. I can choose AirPods in the System Preferences , and the input level meter shows activity, but no activity in the little microphone icon next to dictation when I double-click Fn. – Gabriel Jun 22 at 21:02
  • yes, same for me. – Anton K Jun 23 at 8:00
  • Still a problem for me in 2020 – timbram Sep 2 at 15:23
  • Still unsolved for me (the OP) with 10.15.6 – Gabriel Sep 4 at 12:53
6

Me too :-( I am on the phone with tech support now. Tech support said,

"After doing some research it looks like this is something Apple engineers are aware of and investigating. They have a suggestion to consider using Voice Control as an option."

For the time being, I am using Voice Control... which isn't really a great option IMO.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .