1

Despite the fact that I have tons of mail, the All Inboxes page today displays five messages only. Whereas when looking into the individual mailboxes the problem is eliminated.

enter image description here

I've tried restarting and quitting the mail app but nothing worked out.

  • The problem could be that, you have tons of mails. Try a restart – ankii Mar 18 at 16:59
  • Try changing network. And can you remove the mail account with most emails and readd it if others appear ? – ankii Mar 20 at 15:15
1
+50

Reset the email account within the Mail App

  1. Go to Settings > Passwords & Accounts > Accounts

    • Or Settings > Mail ( or Mail, Contacts, Calendars) > Accounts
  2. Select the mail account that shows the incorrect unread mail notifications

    • If you have more than one, perform these steps for each account
  3. Toggle OFF “Mail” to disable it. This action does not delete your account

enter image description here

  1. Exit Settings by returning to your Home Screen

  2. Close the Mail app by swiping up your Gesture Bar or by pressing the Home button twice. Locate the Mail app preview and swipe up to close it

  3. Now once again go to Settings > Passwords & Accounts > Accounts

    • For older iOS, go to Settings >Mail (Mail, Contacts, Calendars) and select the mail account
  4. Toggle ON Mail to enable it.

  5. Check to see if your mail app is now showing the correct unread email counts.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .