0

I have two Mail.app plug-ins installed: "GPGMailLoader.mailbundle" and "Smallcubed MailSuite.mailbundle". Currenly, GPG is enabled, and works, and MailSuite is disabled.

However, when I toggle either plugin (i.e. MailSuite to on or GPG to off), and restart Mail, the change hasn't taken. So I cannot use MailSuite, nor disable GPG.

I have tried:

  • Reinstalling MacOS Mojave in-place (did not fix).
  • Creating a new user (everything works for new user).

How can I further investigate this?

  • As a new user fixed this, have you tried to reset your Mail preferences and checked it again ? – Udhy Mar 16 at 11:42
  • @Udhy as in ~/Library/Preferences/com.apple.mail-shared.plist? Deleting that did not fix the problem. – Cai Mar 16 at 19:09
0

Eventually I moved my ~/Library/Mail folder to the Desktop, reset mail "to factory settings", then re-imported all messages from the moved folder. It took about a day, including the backup I did first.

Following the above "reset" instructions involves deleting ~/Library/Containers/com.apple.mail/. When I was perusing the new ~/Library/* and ~/Library/Containers/com.apple.mail/* setup, after relaunching Mail, there were differences before and after, in particular which items lived in the container and which lived in the real ~/Library. This may be a clue to a cause, but at least there is now a sledgehammer solution.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .