1

When I tried installing Catalina on a MacBook Pro 15" from 2019, I got a screen saying

macOS could not be installed on your computer.

Some APFS cryptographic state information was unexpectedly unavailable. : (-69461)
Quit the installer to restart your computer and try again.

Retrying didn't fix it. Any ideas?

12

These instructions fixed it for me: https://www.reddit.com/r/OSXBeta/comments/ddh2mj/question_osx_catalina_install_issue/f2y22co/?context=1

Though I didn't boot into recovery mode. I just opened a Terminal when logged in as usual.

First I did:

diskutil apfs list

This showed a list of all volumes, and reported an error code (I don't remember which one exactly) next to the volume described as "VM" (which seems to be the "virtual memory paging partition").

In my case, this volume was "disk1s4" but it may be different for you. I'll call it "disk1s4_changeme" below to remind you to change it to whatever it's called on your machine.

Then I ran:

diskutil apfs eraseVolume disk1s4_changeme -name VM

My understanding is that you don't risk losing any of your own data by erasing the VM partition (your data lives on another partition), but as always it's best to have backups just in case.

Then I ran

diskutil apfs list

again to check that the VM no longer reports the error code, and to verify that it's still "disk1s4".

Then

diskutil apfs chrole disk1s4_changeme V 

to restore the "this is the VM volume" flag. The "V" must be uppercase! Lowercase is to remove flags.

Then

diskutil apfs list

again to make sure it's flagged as a VM. You should expect to see something like

APFS Volume Disk (Role):   disk1s4 (VM)

That's it – I didn't restart my computer or anything.

I just started the Catalina installer, let it do its thing, and it succeeded. Godspeed!

5
  • Just what I was looking for, thanks! – tronmcp Mar 19 '20 at 16:49
  • 1
    Nice! What I was looking for! Thanks! This response fixed the issue! – juniorb2s Apr 15 '20 at 1:57
  • 1
    I was unable to install Catalina for months. Your solution was the only one that solved the problem. Thank you! – Nag Apr 24 '20 at 13:57
  • I do not have enough reputation points to comment above. Pro tip: do not run xartutil --erase-all to remove fingerprint settings on a Macbook Pro (mid-2020). It will remove the encryption keys for APFS from the disk. Your user will be unable to password authenticate and when you reinstall Catalina, you will get the above error. This recommendation resolved the issue. – Michael Dudding Jul 28 '20 at 5:54
  • Thank you. Your answer saved my day. Everything works. System upgraded. – Ihor Aug 29 '20 at 16:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .