0

Here's what I'm working with:

  • MacBook Pro 8,1 (13-inch, early 2011), High Sierra 10.13.6
  • drive is not original to the MBP, it's a Samsung 840 Pro SSD, 500GB, but was swapped out when the machine was near brand-new, so pretty damn old

Issues:

  • one user account (non-admin) no longer appears on login screen
  • admin account has missing-keychain errors
  • running extremely slowly, application icons don't load into Dock or Finder
  • "Can't open System Preferences because the app may be damaged or incomplete" (after long delay)

Actions taken:

  • Booted into safe mode, still running badly, no real difference

  • Tried to run Apple diagnostics (booting while holding down D) Unable to run diagnostics DEC500 Attempting to run Diagnostics from Apple Recovery

  • Tried booting while holding down Cmd+S, I thought I was going to get a to a commpand prompt and try "fsck -fy" to fix file system issues, which I suspected because of the missing user account and keychains

    Instead it went to a "starting internet recovery" screen then to Apple Hardware Test 3A222

    Ran the basic test, result was: Alert! Apple Hardware Test has detected an error. 4xxx/4/40000005: "Battery"

    Ran the extended test, results was: Same result but with a 8 downward-pointing caret characters and an apple character before "Battery"

    Seems likely the battery error is a red herring; found tons of posts on forums saying that you may this error with any 3rd party battery at any time (this battery is 3rd-party, replaced September 2018)

  • Booted in install/recovery mode with Cmd+R and ran Disk Utility > First Aid on volume.

  First Aid process has failed. If possible back up the data on this volume.
    error: (oid 0x117225) om: btn:oinvalid o_cksum (0x2ceae87d1d98eca3)
    Object map is invalid.
    The volume /dev/rdisk2s1 could not be verified completely
    FIle system check exit code is 8
    Restoring original state found as mounted.
    File system verify or repair failed.
    Operation filed.
  • Removed drive, attached to another Mac via USB/external enclosure

    • Disk Utility sees the drive but no volumes under it
    • Mount button is disabled
    • First Aid says "Problems were found with the partition map that might prevent booting"
  • shows up like this from diskutil list command:

  /dev/disk2 (external, physical):
     #:                       TYPE NAME                    SIZE       IDENTIFIER
     0:      GUID_partition_scheme                        *512.1 GB   disk2
     1:                        EFI EFI                     209.7 MB   disk2s1
     2: 7C3457EF-0000-11AA-AA11-00306543ECAC               511.9 GB   disk2s2
  • tried running mounts from Terminal:
   mount /dev/disk2s2
   ount: /dev/disk2s2: unknown special file or file system.

   sudo mount -t hfs /dev/disk2s2 /mnt (after creating /mnt)
   mount_hfs: error on mount(): error = -1.
  • currently trying ddrescue to create an image and see if that can be mounted with any of the previously-attempted means, just to recover some data.

What could be the issue here? I'm trying to evaluate given all of this, whether I might try to reinstall the OS on this drive, or write it off as too old/definitely failing.

Is it at all possible that the issue with the partition table that seems to have screwed this all up was a random glitch that may be solved by an erase and OS reinstall?

2

I believe you're overlooking the obvious:

Removed drive, attached to another Mac via USB/external enclosure

  • Disk Utility sees the drive but no volumes under it
  • Mount button is disabled
  • First Aid says "Problems were found with the partition map that might prevent booting"

Remember, First Aid and fsck can only fix logical problems (filesystem level), they cannot fix physical problems with the drive itself.

Your drive is failing.

One of the tests that should have been run was to get the SMART status of the drive in question (you cannot do this via USB)

$ diskutil info disk0 | grep -i smart

If it comes back as anything but "Verified," you've got a failing disk. This test however, isn't the end-all. It's good for a quick diagnostic, but may give you a false positive. Even if you get "Verified" you'll still want to run a disk utility like Disk Drill or Disk Warrior to do a deeper scan.

Now, given that this is a 2011 MacBook Pro, it's a coin-toss as to whether you should spend money fixing it. A new Samsung EVO SSD can be had for about $60 USD, but no matter how inexpensive the drive, you're still left with a 9+ year old Mac.

Personally, I'd look at either finding a super cheap SSD and resurrect it for knocking about, or I would part it out (worth more on eBay as parts than as a whole) and put the funds toward a new machine.

| improve this answer | |
  • Thanks, that's helpful; gonna accept this answer. I did look at the "S.M.A.R.T. Status" field in Disk Utility and it says "Not Supported" — so just out of curiosity, would I have potentially have gotten a useful answer from that command you posted if I'd run it before pulling the drive out? – RwwL Mar 14 at 15:30
  • 1
    Yes. You can get the SMART info when the drive is attached to the “full blown” SATA controller. The USB to SATA controller is limited to save on cost and usually doesn’t support these functions. – Allan Mar 14 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .