6

Finder shows the Chinese characters 文件 next the md text in the Kind column for Markdown files:

enter image description here

Same is shown in the inspector:

enter image description here

Through Google Translate I found that the characters 文件 mean file in Chinese.

Why is Finder showing the word file in md file in Chinese?
How can I revert it to English?

Here I've uploaded a sample file that shows this behaviour on my machine.

I'm on macOS 10.15.3, the preferred system language is English (UK). No other files show any Chinese characters.

What I've tried

Per suggestion of bjbk I've set the Open with to Visual Studio Code and restarted. This did not change the Kind column contents.

Per suggestion of WGroleau I checked if file README.md returned the same Chinese characters. It does not, it simply returns:

README.md: UTF-8 Unicode text

I've tried using the mdls command on the file, it shows that the content type is com.unknown.md. Maybe that's can help pinpoint the issue?

Full mdls output below:

_kMDItemDisplayNameWithExtensions      = "README.md"
kMDItemContentCreationDate             = 2020-01-20 21:18:03 +0000
kMDItemContentCreationDate_Ranking     = 2020-01-20 00:00:00 +0000
kMDItemContentModificationDate         = 2020-03-14 17:21:13 +0000
kMDItemContentModificationDate_Ranking = 2020-03-14 00:00:00 +0000
kMDItemContentType                     = "com.unknown.md"
kMDItemContentTypeTree                 = (
    "com.unknown.md",
    "public.text",
    "public.data",
    "public.item",
    "public.content",
    "public.plain-text"
)
kMDItemDateAdded                       = 2020-03-14 17:18:56 +0000
kMDItemDateAdded_Ranking               = 2020-03-14 00:00:00 +0000
kMDItemDisplayName                     = "README.md"
kMDItemDocumentIdentifier              = 0
kMDItemFSContentChangeDate             = 2020-03-14 17:21:13 +0000
kMDItemFSCreationDate                  = 2020-01-20 21:18:03 +0000
kMDItemFSCreatorCode                   = ""
kMDItemFSFinderFlags                   = 0
kMDItemFSHasCustomIcon                 = (null)
kMDItemFSInvisible                     = 0
kMDItemFSIsExtensionHidden             = 0
kMDItemFSIsStationery                  = (null)
kMDItemFSLabel                         = 0
kMDItemFSName                          = "README.md"
kMDItemFSNodeCount                     = (null)
kMDItemFSOwnerGroupID                  = 20
kMDItemFSOwnerUserID                   = 502
kMDItemFSSize                          = 97
kMDItemFSTypeCode                      = ""
kMDItemInterestingDate_Ranking         = 2020-03-14 00:00:00 +0000
kMDItemKind                            = "md"
kMDItemLastUsedDate                    = 2020-03-14 17:21:05 +0000
kMDItemLastUsedDate_Ranking            = 2020-03-14 00:00:00 +0000
kMDItemLogicalSize                     = 97
kMDItemPhysicalSize                    = 4096
kMDItemUseCount                        = 21
kMDItemUsedDates                       = (
    "2020-03-13 23:00:00 +0000"
)

0

1 Answer 1

3

The reason you have that text is two-fold:

  1. An application you installed (might even be Sublime Text) defined a new type - namely kMDItemContentType of "com.unknown.md"
  2. CoreServices read the localized description from that app and makes it available to Finder.

To fix this, fix, update or uninstall the app that defined com.unknown.md as a core file type paying attention to the localized text it provides to Finder to display.


Tracking this down will take a little sleuthing since you haven't disclosed the identity of the app that has exerted control as the default app to open that file type. That should be shown in the cropped portion of the get info you showed in your question.

Also, there are layers of programs that can "ask" to open a file type, and layers of file type on each file (shown as kMDItemContentTypeTree) - so depending on the order in which you install apps, the same Mac with the same apps installed might get different results based on the order in which the apps installed, and how you use the apps and if you change and of the spotlight / CoreServices defaults.

To pick this apart, I use a tool lsregister to dump the entire launch services database and parse out items. It's a bit painstaking, but you can always do this if you can't find the app you installed, right click on the icon in question and use Open With... to change the default app to one you prefer how it shows in Finder. Also - now that you know which app Finder is trusting to "name" that new file type/kind - you can open a support request with that software maker to change what's displayed - they likely made a bug in the localization and listed Chinese text for the UK English localized text.

9
  • 1
    This command /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregistermight benefit from more explanation, as it didn't show up as being in my path on the CLI… Commented Jun 7, 2020 at 14:01
  • @LаngLаngС I've edited my answer to point to my current "how to lsregister answer. Let me know if needs updating. If you asked a pointed question on this as follow up - @ me - I would love to answer whatever questions you might have on this deep topic.
    – bmike
    Commented Jun 7, 2020 at 15:05
  • Thx. For now, I guess that I need to learn more about the command itself, which was new to me, as it seems to have moved into the standard /bin paths? (On 10.12 it's still hidden away in /System; so I guess you describe here a 10.14/15 situation?) Commented Jun 7, 2020 at 15:33
  • 1
    Thanks! After I dumped the launch services database I found that TeXShop defined the com.unknown.md type with a Chinese localized name. I've updated TeXShop, but that didn't change anything. I'll see if re-installing it helps. Commented Jun 8, 2020 at 6:25
  • 2
    With /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -v -apps u I wiped my launchservices database, which "resolved" the issue. It reset all file associations though, but that's ok for me. Commented Jun 8, 2020 at 6:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .