4

I'm using macOS Catalina and it's preventing me from sharing my screen in web browsers like Firefox and Chrome, and in other applications too. How do I properly set up permissions so that screen sharing works in all of my apps?

6

Starting with macOS Catalina, Apple has added a new Screen Recording permission to macOS that needs to be granted to every application that tries to record the screen, either for screen capture (saving a movie locally) or screen sharing (transmitting your screen to somewhere else).

Security & Privacy in System Preferences

You can manage permissions for Screen Recording in the System Preferences. However, it doesn't work quite how you would expect! By default the list is empty, as shown below. None of your installed applications are shown in the list, and there is no + button that you could use to add an app. You can't even drag an app into this list.

The Prompt

In order to get an app to show up in this list, you first need to launch the app and activate some functionality inside the app that depends on Screen Recording.

  • If you're using Mozilla Firefox or Google Chrome, the fastest way to do this is by visiting screenapp.io (no affiliation, it just works well).
  • If you're using Safari, go to Google Hangouts, start a new Video Call, and click the three dots button in the top right and then Share Screen.
  • If you are using the paid version of Slack:
    • Create a new private channel with only yourself as a member
    • Click the telephone icon 📞
    • Press the "Share your screen" button in the call window

The first time you do this, you'll see a prompt to grant permissions like the one shown below. Make sure you choose "Open System Preferences" because you'll only be asked once.

If you accidentally click Deny, you'll have to reset your privacy settings for Screen Recording.

Grant the Permission

After clicking "Open System Preferences" you'll be taken right to the Screen Recording section of the Privacy settings. Just click the checkbox beside the app you're trying to use.

But you're not quite done yet! Once you grant the permission, you must quit the application before you can start screen recording. Even though it's quite annoying when you're trying to start a meeting, there's no way around this.

Do it for your other apps now

Because macOS Catalina forces you to quit every app you want to use before you can really use it, I suggest granting permission to as many apps as you can think of now before you really need them. This will save quite a headache when you're trying to share your screen for in a meeting. At a bare minimum, make sure to add Safari and your other browsers (eg. Mozilla Firefox, Google Chrome).

| improve this answer | |
  • This is intended as a canonical answer for issues with Screen Recording permissions on macOS Catalina. – Nic Mar 12 at 22:23
3

I found this suggestion and it worked for me: Make sure you launch that app using Finder and not the app PathFinder or any other launcher (Launchbar, Alfred, etc) this has stopped other apps showing in the list.

| improve this answer | |
  • Thx!!! This is exactly what I was missing!! I typically use Alfred to open apps, and MS Teams was never showing up in the Screen Recording permission list. Open from Finder and boom! Now I can screen share :D – pedorro Nov 13 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .