19

I have a Logitech G600 gaming mouse which I am hoping to use on my MacBook Pro running macOS Mojave. This mouse has a lot of buttons to which I am planning to assign shortcuts.

I have installed Logitech G Hub and when I plug in the mouse it sees it, but it says "NOT CONNECTED" and it doesn't allow me to configure it at all. The basic functions of the mouse work fine even without any software.

I've also tried using Logitech Gaming Software but this doesn't detect my mouse at all.

How can I configure my Logitech gaming mouse on my MacBook?

Here's an example of the problem showing in Logitech G Hub for a G502 mouse:

Logitech G Hub showing the mouse as NOT CONNECTED

2
  • They have now fixed the issue for the G600 in the G Hub 2020.2 update. The issue is very likely still there for other mice. Apr 5 '20 at 7:48
  • I got it to work using the answer's suggestion to install Logitech Control Center first as well. It's so sad but their official G Hub website still states it supports only "macOS X 10.11, 10.12 and 10.13" -- 3 generations behind
    – cryanbhu
    Aug 22 '20 at 4:06
32

After a few frustrating hours I found the solution.

You need to install the Logitech Control Center as well. Once you've installed it, restart your machine and it should now show up as expected in Logitech G Hub.

Notes:

  • If macOS discovers it as a keyboard, close the window and do not try to configure it as a keyboard.
  • If you configured it as a keyboard as above, you can try running this to reset it: sudo rm /Library/Preferences/com.apple.keyboardtype.plist
  • If you're using Karabiner-Elements, this might register it as a keyboard as well, causing issues. Open Karabiner -> Devices -> Basic Configuration and untick your mouse in that list.
8
  • 2
    Hmm, interestingly, when I unplug the mouse, it immediately disappears from G Hub. When I plug it back in, it immediately appears as NOT CONNECTED. Very frustrating. Mar 27 '20 at 23:16
  • 1
    I have a G502 Hero SE and had the same "not connected" problem. The solution worked for me, but I had to completely remove G Hub after installing Control Center. Then I re-installed GHub and it shows up "On-board Mode". I deleted GHub from Applications and re-installed after the LCC install (required manually killing a bunch of GHub processes using terminal).
    – Nate Stone
    Mar 28 '20 at 15:11
  • 2
    I had to do this and the thing in the other answer.
    – Daniel
    Jul 24 '20 at 19:09
  • 5
    Karabiner for me. Very nice find Vlad!
    – Tokuriku
    Dec 3 '20 at 4:40
  • 1
    THE FOLLOWING worked for me: Install G HUB, plug mouse in - NOT CONNECTED. Make sure that in System Preferences >> Security & Privacy >> Accessibility >> G HUB is checked! Then restart!. This worked for me. I tried Logitech Control Center, but there nothing showed up. So I ignored Control Center und finally uninstalled it after G HUB worked
    – Fab1n
    Dec 9 '20 at 8:24
12

IF YOU'RE RUNNING CATALINA, then thereal issue is likely related to its new security features. You don't need to install any additional software. You just need to follow the steps below to make sure everything's set up right. Unfortunately these installers don't quite "get it right" on Catalina.

  1. Go into System Preferences >> Security & Privacy

  2. Click the Privacy tab.

  3. Select Accessibility from the left pane

  4. Check that Logitech G HUB is CHECKED Image showing Logitech G HUB setting in Accessibility Make sure Logitech G Hub is checked for Accessibility. If it's not already checked, this is likely your problem. Check it, then proceed to step 5.

  5. Exit, then re-launch the G Hub app.

  6. If it still shows disconnected, unplug and replug mouse

  7. If it still shows disconnected, uninstall and reinstall G-Hub (I had to do this) a. Exit G Hub (obviously)

    b. Open Finder, go to Applications folder

    b. Delete the Logitech G Hub app (move to trash)

    c. Re-install G Hub the same way you did before.

You're mouse should show up correctly now and let you customize, etc. The key here step 4, which is just one of those things that are now required with Catalina. If you're lucky you'll only have to go through step 5. In the worst case, you might have to do all steps through 7c. A reboot somewhere between steps 5 and 7c might actually make it work, too, but I'm only listing the steps I actually performed - I hate rebooting.

Hope this helps!

2
  • 1
    I had to do this and the thing in the other answer.
    – Daniel
    Jul 24 '20 at 19:09
  • This answer works. The only change I would suggest is that on first install of G Hub it asked access of my screen sharing or recording (something like that) which I did not do because of privacy concerns. Also when opening the security options in system preferences I could not locate G hub under privacy tab. So I reinstalled G hub and then it showed under privacy tab in system preferences, but still my mouse wasn't connected. I restarted my laptop, Disconnected and reconnected my mouse and it worked. My mac had OS Catalina 10.15.5 Sep 28 '20 at 21:58
1

If using Logitech Control Centre or Logitech Gaming Software, you may need to allow a System Extension to be loaded. In System Preferences > Security & Privacy click on the General tab and choose Allow at bottom right to allow the extension to be loaded. Security & Privacy macOS Catalina

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .