1

I followed instructions here: Default Browser .plist location

But it does't work. My custom app doesn't show up in the list of browsers to choose from in system settings:

enter image description here

I have tried:

  • calling /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister on the modified plist file.
  • moving the custom app to /Applications

What does it take to get this to work on macOS mojave? Thanks

2
  • 1
    for a weird approach, I'd take the plist of the chrome app & put it in your app's "show package contents". Remove all the extra info or modify them to point to appropriate executables
    – anki
    Mar 11 '20 at 17:38
  • I solved the problem using swda from SwiftDefaultApps.
    – ssppjj
    Mar 22 '20 at 15:33
1

I eventually solved the problem using SwiftDefaultApps command line tool swda. It works. Although, this box now shows up blank in system setting.

swda is located inside the zip file of the latest release at https://github.com/Lord-Kamina/SwiftDefaultApps/releases

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .