My Mac running Lion was being slow, so I was decided to reinstall OS X. I don't have any Time Machine backups.

Everything went file, but in the middle of the installation, it got stuck, and later the installation failed without any reason. So, I tried to reboot again, but it said that the reinstallation failed and asked me to reinstall again. I tried to reinstall, but nothing came up.

So I tried to use Disk Utility to erase the startup disk and make a new partition. But, when trying to partition, Disk Utility said that it cannot unmount the disk. In Disk Utility, I found another disk called disk2 and Mac OS X Base System. As far as I know, I didn't see that disk2 in my disk list before.
I tried to unmount it or erase that disk2, but it won't let me. So I tried using Terminal to force unmount that disk, but still it doesn't let me.

Is that disk2 the reason why I cannot partition my main HD? How can I unmount or erase that disk2 Mac OS X Base system ?

I would like to clean install OS X lion again. I already have a boot image on my USB drive. I just cannot start it because the installation fails and something is still running, I guess.

Screenshot of Disk Utility:

enter image description here

  • i have the exact same problem, except that when i reste the pram and nram, the "Mac OS X Base System" still appears and i can't do any clean install.. what do you suggest?
    – user28636
    Sep 5, 2012 at 22:20

2 Answers 2


The Mac OS X base system image is not the cause of your problem. See What is the 'Mac OS X Base System' disk image on my 2011 MacBook AIr? for an explanation.

My best guess, based on the screenshot, as to why you can't repartition the Hitachi disk is that it's the current startup device. You need to restart your computer from an an external device—preferably a device that has the Lion Installer on it-if you want to reformat the drive. Otherwise, assuming you have a valid recovery partition, you can erase the Mac partition itself and reinstall Lion without an external device.

Perhaps Apple's Mac OS X 10.7 Help: Recover your entire system document will help you.

  • Yes, just now I solved the problem setting PRAM and lion installer let me install fresh again. Thanks. Jan 27, 2012 at 4:27
  • Glad to be of assistance.
    – jaberg
    May 12, 2012 at 1:22
  • 1
    @jaberg, Link down.........
    – Pacerier
    Jan 4, 2018 at 4:57

I think you need to reset your PRAM (for older Mac computers) or NVRAM (for newer Mac computers):


Resetting PRAM or NVRAM

  1. Shut down the computer.
  2. Locate the following keys on the keyboard: Command(⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
  3. Turn on the computer.
  4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
  5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
  6. Release the keys.

This should get rid of the "Mac OS X Base System" virtual mount, and allow you to clean install from your Lion USB drive

  • worked like a charm! thx
    – Eugene
    May 11, 2012 at 20:58
  • Can someone explain why does this occur in the first place?
    – Pacerier
    Jan 4, 2018 at 4:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .