15

When using any keyboard shortcut in any application, there is a beeping sound effect that is normally played when there is an error. However, the keyboard shortcut still works normally. I am using macOS Mojave 10.14.6.

3
  • 1
    try to do this: support.apple.com/en-us/HT204063 . It should fix it
    – Udhy
    Commented Mar 10, 2020 at 14:25
  • 1
    If the NVRAM reset does not work: Do you hear the sound for all Keyboard-Shortcuts?
    – Ant
    Commented Mar 10, 2020 at 14:41
  • 1
    @Udhy Thanks, the NVRAM reset worked.
    – izhang05
    Commented Mar 16, 2020 at 1:20

5 Answers 5

22

Restarting the Dock fixed it for me.

Open up Activity Monitor, locate the Dock process, and Quit the dock.

4
  • 1
    @Community All steps needed to complete the task already provided in my answer.
    – camursm
    Commented Sep 6, 2021 at 15:06
  • 4
    I can confirm that this fix worked for me - I now get the sound effect only when an error occurs (eg trying to command-C when nothing is selected) whereas before it beeped even when the command was successful. Thanks! Commented Sep 13, 2021 at 7:59
  • 1
    Thanks. This was very annoying. Your solution worked for me Commented May 24, 2022 at 17:24
  • 1
    This worked for me. It also fixes another issue where letters typed in Launchpad search are duplicated. Commented Jan 3, 2023 at 17:35
3

On your Mac, choose Apple menu > System Preferences, click Sound, then click Sound Effects.

Find the alert sound that is causing the issue. When you click on it, it will play the sound effect. In my case, every time I used the keyboard shortcut cmd-shift-p - even though it was a valid shortcut in some apps - it made the alert sound from "Ping". I muted the Output volume for "Ping" and that solved the issue.mac sound effects

1
  • Thanks @Allen, I thought the sound was coming from the <b>Terminal</b> app. Realized that it was the Play Sound was being triggered each time I hit backspace on empty command line.
    – Jed
    Commented May 27, 2021 at 6:43
2

It has just happened to me as well.

For me, it turned out that a specific app (VPN) has blocked the input from my keyboard. When I closed the app, the keyboard immediately returned to work properly (no reset was required).

Try to close apps that start-up with your Mac, perhaps one of them is taking control over your input.

0

It appears that this sort of issue can easily be caused by a glitched application reacting to the input. It doesn't have to be foreground for this to occur. Most recent example happening to me was telegram's save dialog left in the background. It caused beeps to occur with use of the cmd key and use of the space bar in other applications, as well as preventing QuickLook from closing a window once it was opened.

Diving this sort of issue in the past has been as follows : Check open applications, restart, possibly test vs a fresh 'test' user account if it persists to rule out items unique to your user account. Check and possibly reset the shortcuts in system preferences. Examine anything installed for all users as a culprit. Move on to removable hardware.

0

I have the same issue with FortiClient. I have to close it/restart it to get it to work.

Prior to my understanding that it was an issue with FortiClient, I used to restart my Mac every time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .