2

I've been using a 2010 iMac with OS 10.9 for a few years. Now I need to update the OS to 10.13 (the latest one this system supports).

Here's the catch: months ago I attempted to install 10.13 on an SD card plugged into the system. The install failed, possibly because it ran out of space on the card. But now when I go to the App Store and try to download 10.13, it tells me the version is already installed. It's not! It still boots 10.9 from the internal drive.

Removing the SD card and rebooting had no effect. I tried reinstalling the OS in Recovery mode and it said it was unable. So now I'm in the process reverting to 10.9 from Time Machine.

I presume there is some sort of config file lurking somewhere, left over from my failed install to the SD card, that tells the system I have 10.13 installed.

I've searched for instructions on making a bootable High Sierra installer on a USB stick but what I've found seems obsolete and doesn't work.

I seem to be stuck between a rock & a hard place. Any ideas? (I read recently that installing Catalina on an external drive would corrupt your main drive; am I looking at something similar here?)

1
  • I've searched for instructions on making a bootable High Sierra installer on a USB stick but what I've found seems obsolete and doesn't work. Can you share the instructions that you have found and find not working?
    – Nimesh Neema
    Mar 6 '20 at 8:27
1

Spent a fruitless hour on the phone with Apple support—nothing I tried had any effect. Finally solved it by downloading the High Sierra installer on another, newer Mac, and using its Terminal's createinstallmedia command to make a bootable USB thumb drive installer. Transferred this to the target iMac via sneakernet, and was able to run it and install High Sierra.

0

Does the following link work? It should bring you a page where you can download High Sierra, even if it's installed.

https://itunes.apple.com/us/app/macos-high-sierra/id1246284741?mt=12?mt=8&uo=4&at=10l69J

5
  • Tried it on an old Mac running 10.11. Another gotcha! App store just said "This version cannot be installed on this computer." Will try it on a newer machine.
    – Rob Lewis
    Mar 6 '20 at 14:30
  • The download works on a Catalina machine, but (naturally) it aborts the install saying that the version is too old to be installed. But where is the downloaded installer? Can't find it in the Downloads folder or the Trash. Will try it on the actual target iMac if it will boot. Can it be installed in Recovery Mode?
    – Rob Lewis
    Mar 6 '20 at 14:54
  • Interesting: just found this Apple document that says if you boot with Opt-Cmd-R it will "Upgrade to the latest macOS that is compatible with your Mac." Sadly, another gotcha: this only works if the machine has had 10.12.4 or later installed at some point.
    – Rob Lewis
    Mar 6 '20 at 15:06
  • Grr. Finished Time Machine restore of 10.9 (which thankfully worked). Went to the link you suggested and the App Store shows High Sierra but, again, has it marked as "Installed" and doesn't offer to download. Now what? (I have a USB stick with an El Capitan installer; maybe this could be a path to getting High Sierra?)
    – Rob Lewis
    Mar 6 '20 at 15:44
  • @RobLewis On the Catalina Mac, it should be in /Applications. People have posted direct URL links to apple downloads for High Sierra, so there should be one somewhere.
    – benwiggy
    Mar 6 '20 at 16:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .