5

I'm not a Mac power user by any stretch of the imagination, but I'm hoping for some help from someone here that is. There are similar questions being asked, but the answers seem to all be similar... that the person asking the question doesn't have high usage.

I have a iMac Retina 5K, 27in, 2017 with a 3.4Ghz i5. Purchased a year ago and barely use it, so it's basically brand new. I just recently upgraded to Catalina version 10.15.3. my iMac has been unbareably slow since the Catalina install. it barely worked with 8GB of RAM and an Apple support person took a look at my iMac and saw that I was using 7.6GB of memory and suggested I downgrade to Mojave or install more RAM, so my first step was to remove the 8GB and install 32GB. My iMac is running only slightly faster with the 32GB installed. It stopped crashing on a daily basis, which is great, but things still take a while to open after I click on them. I still get the spinning beachball and if I look at Activity Monitor my memory pressure is in the red even when I have nothing running (except for Activity Monitor).

The attached screenshot is taken about 5mins after turning on my iMac and the only thing I have running is Activity Monitor.

Is there something wrong with Catalina? Is something wrong with the memory I installed? Why is my memory pressure in the red? Does it have something to do with sharingd or suggestd? They are always at the top of the list.

Any suggestions on what I should do?

Thanks

activity monitor

  • Not sure why but the amount of memory being used by sharingd and suggestd processes on your computer seem to be way above normal. 32 GB of RAM is a pretty good level of RAM. – Alper Mar 6 at 4:06
  • Do you have an iCloud subscription? If so, is it turned on and do you have any idea how big your user data files (documents, pictures, videos, etc.) are in total? – Alper Mar 8 at 13:14
  • Alper I have the free 5GB iCloud account. I'm using about half of it. – Decatur-ish Mar 12 at 19:30
  • I think @benwiggy's added suggestions about removing some other files or folders from your iMac's user library and seeing what happens make sense. I added some new suggestions (or old ones with a bit more detail) If that has not worked (or does not work) and you still have the same problem. – Alper Mar 14 at 23:20
4

I too started experiencing this problem after I installed Catalina on my 2019 iMac Retina 5K with 3.6 Ghz 8-Core I9 processor and 32 GB memory (4 days ago). I had no such problems prior to my upgrade. I turned off Airdrop with no effect. Unfortunately, I can't disable remote disks as I'm very much in need of icloud and screen sharing. I tried turning off all my other icloud devices, but that didn't seem to have any effect either. My CPU usage by the "sharingd" processis 15 times higher than my next most CPU intensive process. It also appears to be cycling up to 100% plus CPU usage for about 5-10 seconds every 20-30 seconds. Fan speed is also varying in line with the cpu temperature, as would be expected (1200 RPM goes to 2400 RPM).

I tried taking the issue to Apple Support, but even after getting pushed up to 2nd level, they were no help. They seemed clueless about what sharingd does and how to troubleshoot it. They basically ran me through POPO and SMC Reset and then gave up. They suggested it must be a hardware problem even though diagnostics ran clean and no other evidence supports that conclusion.

I've also tried shutting down all my 3rd party apps and no effect from that either.

I am now wondering if possibly Apple is running some form of file conversion/tweaking on my icloud stored photos, movies, or music in background as part of the upgrade and maybe this is causing file sync issues. If so, hopefully it will eventually finish and go away! But I'm not hopeful. Personally, I think it is a Catalina bug that Apple is not yet acknowledging.

UPDATED 4/19/2020 (PROBLEM PARTIALLY IDENTIFIED and TEMPORARY FIX)

After further investigation, I found that turning off icloud on my system (or turning off the network so it couldn't talk to icloud) caused sharingd to go quiet (vs. near 100% CPU utilization). I also started to notice that the process AddressBookSourceSync is also running (at moderate levels) when sharingd is running at high CPU. On a hunch, I turned my icloud back on, but just disabled Contacts (in System Preferences > AppleID). With Contacts off, my system is back to running quietly. Therefore it appears that the high CPU utilization of the sharingd process somehow relates to trying to sync with Contacts (address book) in icloud. So at least I have a temporary fix (i.e. turning off contacts, except when needed), but caution, losing contacts has negative impacts on identifying people in imessage threads, etc. So admittedly this is a very limited fix.

FIXED 5/3/2020 (at least on my system)

Realizing my above temporary fix was not cutting it for me and still being suspicious that my address book system (Contacts) was somehow corrupted during my upgrade to Catalina, I decided I needed to completely unload and reinstall my local copy of my address book system. Not knowing exactly how to do that, I searched and found this article https://ugetfix.com/ask/how-to-fix-addressbooksourcesync/ which walked me through the process. This procedure should work as long as your local address book is synced with iCloud. Although the article addresses symptoms I didn't have, it did the trick as far as allowing me to unload and reload my local address book system. Once I performed this procedure it was immediately apparent that this fixed my problem with high sharingd process CPU usage and the corresponding high memory usage by addressbooksourcesync. My sharingd process is now only using small amounts of CPU, somewhere approximately in the range of .1% to 4.5% CPU (vs 100+% CPU previously). AddressBookSourceSync's memory use also is much lower now too, about 300MB vs. Gigbytes prior to the fix (sorry I forgot to record the exact memory usage initially). I don't know if this will help others, but it might be worth a try. Just make sure your local addressbook (Contacts) and icloud addressbook (Contacts) are in good syncronization before you start. I also added one step to this procedure as an added measure of safety. I exported all my Contacts to a PDF file prior to starting. I did that just in case something went horribly wrong and I had to re-enter them manually. Fortunately, that was not necessary! One last comment: for whatever reason, I found no .plist file (the one that the author of this procedure mentions) in my ~/Library/Application Support/Address Book/ folder, either before or after performing the procedure.

| improve this answer | |
  • Thx for that insight. This is not my particular issue but good to know about it and will keep in mind about disabling contact sync to icloud – javadba Apr 25 at 21:53
1

I experienced a similar problem or better to say a series of problems.

The first one was that if I deleted a huge amout of data on a drive, the information about the free space didn't change. I deleted up to 400GB and nothing changed. The next problem was that I started to get low memory warnings while running Final Cut Pro X. I had 24GB installed and I never experienced this before in Mojave with the same type of projects. I upgraded the memory to 48GB and I was still surprised by the extreme RAM usage. After some time the CPU started to get very busy, even if there was nothing going on.

After some googling I found that it was caused by a kind of virus, which is probably originated by a developer who makes a software which is supposed to clean Your Mac. So people start getting this problems, they search on Google and get an offer to buy such software, which will delete the virus and the customer is happy for buying such a useful software.

So what You need to do is deleting all browser data in the browser(s) use use, including cookies, history and cache. This should solve the problem as it did in my case.

Here is a link to the article I followed:

https://macsecurity.net/view/325-your-computer-is-low-on-memory-mac-virus

| improve this answer | |
1

Is there something wrong with Catalina?

The OS always has a part to play in any problem, but it's only one of many components.

Is something wrong with the memory I installed?

Unlikely: it's available and being used.

Why is my memory pressure in the red? Does it have something to do with sharingd or suggestd?

Indeed it does.
suggestd is daemon that processes user content in order to detect contacts, events, named entities, etc. It receives content from Mail, Spotlight, Messages and other apps.
sharingd is used by the Finder to enable AirDrop file sharing, connecting to shared computers, and accessing Remote Discs from other computers.

What should I do?

You have reported that other user accounts work normally. That means you have pinpointed the cause to something within your user account. So reinstalling the OS won't help. Some people might recommend migrating everything to a new user account, but it's actually better to solve the problem here. (If it happens again, will you move to another user, and another...?)

The cause is therefore something in your user Library. Possibly something in the Preferences subfolder. There is also a subfolder called "Sharing", which might be at fault. The Preferences subfolder may have files called com.apple.sharingd.plist and com.apple.suggestd.plist which you could delete. Anything with sharing and suggest in the filenames: delete!

You can safely delete anything in the user Library and test whether it improves things. Firstly, you've got a backup, so you can always restore stuff, and secondly because deleting everything just leaves you with the equivalent of a 'new' user account: the OS sets everything to default.

Of course, there will be things you want to keep, so don't go mad. Remove something, reboot and test. Put it back if no effect.

| improve this answer | |
  • Thanks for the reply benwiggy. – Decatur-ish Mar 7 at 2:43
  • @Decatur-ish I've added some bits based on your comments below. – benwiggy Mar 7 at 9:46
  • "This is not a commonly reported problem" I"m not so sure about that - i have similar issue and getting plenty of "nods" from other folks. – javadba Apr 25 at 21:49
0

Welcome to Ask Different!

Pls try these measures and see if they help:

Short-term

See if you can Quit or Force Quit either the sharingd or suggestiond process: you can do this by selecting either process in the Activity Monitor and pressing Option ⌥+Command ⌘ +Q.

If you can quit either, this would speed up your computer until the next reboot.

Long-term

  1. Go to System Preferences > Sharing and see if any of the listed services (Screen Sharing, File Sharing, etc.) is enabled. Disable any that is enabled.

  2. Right-click or control-click after selecting the line below and select Services > Show in Finder

~/Library/Suggestions

This should open a Finder window with the "Suggestions" folder selected. Delete (or Move to Trash) the "Suggestions" folder in the Finder window.

  1. Empty your computer's Trash.

  2. Restart your computer and see if memory usage has decreased and your computer has sped up.

Other long-term

  • Turn iCloud off and on: Assuming you have nothing exclusively on iCloud, sign out of iCloud on your iMac, restart your computer and see if there is any notable improvement in the computer's memory usage. See these warnings and directions about turning off the iCloud from Apple support in case you wish to try this but note that the copies of the files also on the iCloud already stored locally on your iMac are not deleted from your iMac when you sign out of the iCloud.

Even if turning off iCloud fixes the memory problem, I would suggest turning it on again and see what happens. You may have to wait for a while depending on the size of your user data files for a full sync with iCloud when you turn it on again.

  • Migrate to another iMac user: Considering the nature of the problem, it would be wise to move only the user data files (any documents, pictures, music and video files, etc.), but not the user system setting and customization files such as those under the ~/library/ folder. That means you have to restore your documents, pictures and music folders yourself from a backup or copy them from under your existing iMac user and then have the respective programs such as the Music app or the Photos app manually recognize their respective files in case necessary.

I think the easy way to transfer pretty much all of the user data files (but not the user system setting and customization files) would be to sign in with the same iCloud account from your new iMac user (iCloud syncs the user data files, not the user system setting and customization files) assuming all user data files have been recently synched from the existing iMac user.

  • Reinstall Catalina: Same precautions about moving of only the user data files are advised if Catalina is reinstalled
| improve this answer | |
  • Part 1 Thanks for the reply Alper. So I tried your measures, and they do help for a short time and then I'm back at memory pressure in the red. I wish I could post more screenshots at this point, but don’t see an option to do that. So here’s where I’m at: Short-term I can Quit and/or Force Quit sharingd and suggestd, but they instantly reappear in the list. I do get a temporary reprieve from the high memory usage, but the usage creeps back up to red rather quickly. – Decatur-ish Mar 7 at 3:46
  • Part 2 If I quit just suggestd my memory pressure will fall from red down to orange, but it only lasts for about a minute and a half and then the meter is back in the red. Sharingd seems to be the real problem. If I quit just sharingd the meter drops all the way down to very low green and my memory used goes to 6GB, but again, it’s only temporary. 5 and a half minutes later the my memory used is up at 31GB and the meter starts to climb. 2 minutes later the meter hits red and stays there. So yes, its a very short-term fix. – Decatur-ish Mar 7 at 3:46
  • Part 3 Since the problem seems to really be with sharingd are there other things I can try to turn off this feature or uninstall/reinstall it, reset it? Long-term I checked all of the listed services under sharing and nothing is enabled. I also went into Library and tossed the folder into the trash, emptied the trash and restarted. Memory usage has not stabilized. If helpful, I do want to note that I set up a test account on my Mac (at the request of an Apple support person helping me with this problem). – Decatur-ish Mar 7 at 3:48
  • Part 4 When I log out of my primary account and into the test account I’m amazed at how well things work. All the Apps just open right up. Safari goes right to websites. My Mac works like a brand new machine, which it practically is. My memory usage sits at 5.15GB on the test account if I’m not running anything besides Activity Monitor. – Decatur-ish Mar 7 at 3:49
  • Part 5 Do you or does anyone else have suggestions? Should I call Apple for support? Should I try reinstalling Catalina… or will restoring from a backup just put the same problem back on my iMac? – Decatur-ish Mar 7 at 3:49
-1

I experienced this problem when I installed Catalina. I had to revert back to Mojave to solve the sluggishness. Thank goodness I had a backup on Time Machine, but it was a long and nail-biting process. I also had upgraded to 32GB, which is what allowed me to remove Catalina. I think. My Mac is an early 2014 and is happy without Catalina. It would be nice to hear that Apple is working to solve this problem. No word, so far. I am considering moving to the latest iMac.

| improve this answer | |
  • Thank you Dorvaldude. – Decatur-ish Mar 7 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .