0

I bought two Dell S-Series 27-Inch monitors and they both display the image, the problem is that they are mirroring each other, it's like it doesn't find the other monitor. This is the docker I'm using

What I tried:

  • Reset SMC
  • Bootcamp (works excellent, I can see the two screens how it should be)
  • General info
  • Updates (there are none, it's up to date)
  • Reset NVRAM
  • Pressing Option -> "Detect Displays" on bottom right corner

Look below:

enter image description here

That's with the lid open, if I close it, it only shows me this:

enter image description here

Now what I wonder is why are those two profiles there? Is it recognizing the other monitor but not doing anything? EDIT: the profile doesn't seem to be involved in this, still not 100% sure

Any ideas?

7
  • 1
    How are you connecting the monitors and to which port(s)? – Allan Mar 5 '20 at 0:28
  • Through a docker, I skipped that part. I updated it above with the link to it @Allan – Arturo Mar 5 '20 at 0:31
  • Ahhh...so a single connection. Try bypassing the dock and plug each monitor into a port on your Mac. This is technically daisy chaining and macOS doesn't support it – Allan Mar 5 '20 at 0:39
  • When you say plug each monitor into a port you mean connect it to a different USB-C from the mac? Sorry you got a little too tech there. @Allan I tried connecting it with USB upstream port but doesn't work either – Arturo Mar 5 '20 at 0:42
  • 1
    Each monitor needs to be connected to a USB-C port on the MBP. Don't go through the dock. – Allan Mar 5 '20 at 0:56
0

Not sure if this would work for you, but my MacBook Pro was not detecting a Dell 2nd screen while my buddy's older MacBook Pro did.

All I had to do was reseat the cable on the monitors side - the pins were a bit loose and I just tightened them all the screws all the way.

0

The problem was that mac doesn't allow to plug in multiple monitors using the same port. I was using a dongle to connect 2 monitors.

Solution:

Monitors need to be pluged-in in different ports.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .