1

Recently, I started having problems with my MacBook Pro. Everytime I try to shut it down, the Terminal tab opens and shows the message on the picture (root#/usr/local/VASCO/NativeBridge/startup.sh ; exit;)

I do not understand at all where the problem lies. I have tried to delete the VASCO plug-in, but it doesn't work.

Do you have an idea of what the problem might be?

Many thanks!

J.

enter image description here

  • Are you using Terminal or iTerm2? – jmh Mar 4 '20 at 20:26
  • Terminal is the tab that pops up everytime I try to shut down. There is no way to shut it down as the Terminal tab does not want to close. It says that all sh, digipass-nativebridge-monitor, digipass-nativebridge process will stop if I shut down the computer. I have no idea what this means. – Jiminy Ji Mar 4 '20 at 20:32
  • When I try to shut the Mac down, I am asked if I really want to stop the running process underway in this tab. But I did not even open Terminal myself in the first place. I hence cannot see what process they are talking about... – Jiminy Ji Mar 4 '20 at 20:37
  • 1
    /usr/local/VASCO/NativeBridge/startup.sh is not a default part of macOS and if you didn't install it and this is a personal computer then you need to ascertain its origin and purpose and deal with it in an appropriate manner. BTW I would not change any of the profile settings in Terminal as suggested in the answer by jmh because all that would do is hide the underlying issue not really resolve it in a proper investigative manner as really should be done! – user3439894 Mar 5 '20 at 6:18
  • Thank you for your input. Unfortunately, I am not very good with computers. The only thing I know is that VASCO is the plugin used to read banking cards on my computer. So I might have installed the plugin to allow for the use of my card. Should I delete the plugin/ card reader altogether? This is the first time this has happened though and I didn't install the plugin recently. This was months ago. – Jiminy Ji Mar 5 '20 at 9:02
-1

Open terminal and under the Terminal menu item click on preferences. This will give you the pane shown below.

enter image description here

From this pane click on Profiles in the upper left corner of the pane and notice below the Profiles pane but to the right there is a set of tabs. Click on the Shell tab. This opens a pane shown below.

enter image description here

Notice that around the middle of this pane is the phrase: Ask before closing. I've drawn a red rectangle around this. Now make sure the Never button is checked.

  • Why the down vote?? – jmh Mar 5 '20 at 1:32
  • Thank you for your input. – Jiminy Ji Mar 5 '20 at 9:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .