1

My printer is HP LaserJet M15A connected via USB to my router. Currently, I'm running on macOS Catalina version 10.15.13. I can see and add the printer under "Printer & Scanners" - "Windows" - workgroup - fastgate - "HP_LaserJet-M14-M17_VNC3B87838". The add seems to be done correctly (using the correct driver), but when trying to print I see "Unable to connect to printer". My router is Technicolor MediaAccess DGA4131FWB. I tried many stuff to fix the problem, but nothing works:

Added the following lines to my nsmb.conf [default] port445=both smb_neg=smb1_only signing_required=no

Tried to set manually the ip of the router (192.168.1.254) and ports (80,139,445,631 and all the other opened ports) from CUPS but no result. The output of nmap 192.168.1.254 is: PORT STATE SERVICE 53/tcp open domain 80/tcp open http 139/tcp open netbios-ssn 443/tcp filtered https 445/tcp open microsoft-ds 631/tcp open ipp 5000/tcp open upnp 8080/tcp open http-proxy 8888/tcp open sun-answerbook 49152/tcp open unknown

I can also print correctly from my Desktop PC with Windows 10, and from my Android smartphone using PrinterShare. But not on Mac.

Anyone have any idea what's wrong? Thank you

You must log in to answer this question.

Browse other questions tagged .